table cell problem spanning multiple columns when a column has style attribute visibility: collapse in COL tag

RESOLVED DUPLICATE of bug 354846

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 354846
7 years ago
7 years ago

People

(Reporter: Hubert Kauker, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)
Build Identifier: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)

Suppose we have a table of three columns.
They have a common header cell spanning all three columns.
Each column has an associated COL tag.
The middle one has style attribute visibility: collapse.

The header is then NOT centered across the two visible columns.
It is rendered instead as if all three columns were still visible.


Reproducible: Always

Steps to Reproduce:
<!-- Example -->
<table border="1">
	<colgroup>
		<col >
		<col style="visibility: collapse">
		<col>
	</colgroup>
<thead>
	<tr>
		<th colspan="3">Demo Table</th>
	</tr>
	<tr>
		<th>First col</th>
		<th>Second col</th>
		<th>Third col</th>
	</tr>
</thead>
<tbody>
	<tr>
		<td>1</td>
		<td>2</td>
		<td>3</td>
	</tr>
</tbody>
</table>

Actual Results:  
Header cell is centered across all three columns, as if middle one were still visible.

Expected Results:  
Header cell should only be centered across the two visible columns.
Created attachment 519605 [details]
Test case

Updated

7 years ago
Status: UNCONFIRMED → NEW
Component: DOM: Core & HTML → Layout: Tables
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
QA Contact: general → layout.tables
Hardware: x86 → All
Version: unspecified → Trunk
Attachment #519605 - Attachment mime type: text/plain → text/html
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354846
You need to log in before you can comment on or make changes to this bug.