The default bug view has changed. See this FAQ.

Web Console REPL "readline" occasionally stops working right

VERIFIED FIXED

Status

()

Firefox
Developer Tools
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Wesley W. Garland, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

6 years ago
Sorry for the empty submission, I think I hit 'enter' instead of double-quote while typing in the subject line.

Anyhow -- when using the Web Console, I frequently bump into a situation where the REPL stops evaluating the input when I press 'enter'; instead it will print a newline on the screen; i.e., increase the size of the input area, and place the cursor beneath the input prompt.

When this happens, the only resolution is to close and re-open the Web Console.

This is triggered when I enter code that the Web Console doesn't seem to be allowed to evaluate; I keep bumping into this when trying to debug errors related to cross-domain frames, same-origin XHR, etc.

I suppose there is an outside chance this is related to bug 642108.

Wes
Summary: Web Console REPL → Web Console REPL "readline" occasionally stops working right

Comment 2

6 years ago
It could be related to that other bug. I must say that those both sound unusual. I haven't encountered either one of these problems.

(By the way, what you're describing is the behavior you should get with shift-enter)
(Reporter)

Comment 3

6 years ago
Interesting - is it possible that this is a Leopard-specific problem?  I frequently encounter these issues on both my home and office Macs, which are both still on 10.5.
when this happens, do you see anything suspicious in the Error Console (cmd-shift-J to open it)?
I guess I should've looked at bug 642108 before posting that. :)

Any common steps to cause this to happen that you can think of?

What types of code are you evaluating in the input line?

What types of pages are you evaluating against?

Need more data!
Based on testing, this bug is most likely caused by bug 642108.

The jsterm input stops working once you bump into bug 642108. Work around: clear console output - no need to close/reopen.
Wesley: can you please retest for this bug with the latest nightly? It should be fixed by bug 642108. Thanks!
pinging Wes. Are you still seeing this problem in nightlies?
I'm marking this fixed. Please reopen if the problem reoccurs.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Mac OS X → AIX
Resolution: --- → FIXED
AIX?
OS: AIX → All

Comment 11

6 years ago
I think it stands for Alien Unix.
not far off. Just wondering how I managed to flip that in the bug?

Comment 13

6 years ago
Verified on Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110502 Firefox/6.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.