[REGRESSION] UW IMAP: Didin't get the correct "New folder dialog with options" for the first launch

NEW
Unassigned

Status

MailNews Core
Networking: IMAP
--
major
18 years ago
8 years ago

People

(Reporter: BenB, Unassigned)

Tracking

({imap-interop, regression})

Trunk
x86
Linux
imap-interop, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Reproduce:
1. Log into UW-IMAP account (with the flag "supports folders that contain both
msg and folders" in advanced properties unsat)
2. Via New folder... in the content menu of a folder, try to create a folder
that can contain subfolders.

Expected result:
A radio group lets you select, which type of folder you want to create.

Actual result:
No radio group.

This is a regression. It works fine in 0.6.
(Reporter)

Updated

18 years ago
Keywords: interop, regression
QA Contact: esther → huang

Comment 1

18 years ago
Ben, can you try again? It seems it's working if you open the new folder dialog 
from the second time......problem seems only occurring on the first time new 
folder dialog.....

Comment 2

18 years ago
Try doing the new Folder second-time. The radio-group will appear correctly.
This is a known problem and not a regression. 

Comment 3

18 years ago
Updating the summary to reflect the real problem..
Summary: [REGRESSION] Cannot create folder-only folder → [REGRESSION] UW IMAP: Didin't get the correct "New folder dialog with options" for the first launch
(Reporter)

Comment 4

18 years ago
It is true that it works the second time. However, it is indeed a regresssion -
I see the radio group directly the first time in 0.6.

Comment 5

17 years ago
What happens if your current folder is not on the specific IMAP account, instead
it's on an account (e.g. local folders) that supports messages and subfolders?
It seems to me that you can change the selection to your IMAP account but you
still won't get the options.

Updated

16 years ago
QA Contact: huang → meehansqa
(Reporter)

Comment 6

16 years ago
It seems like this problem morphed somewhat.

I now get a radio group for selecing message- or folder-folders. But I don't get
OK or Cancel buttons. They are there, but the size of the dialog is just so that
they are hidden (without it being obvious that they are hidden). But if I resize
the dialog and use it, it has no effect. No folder gets created. I can repeat
it, get the correct dialog this time and this time it works (no failure,
although I use the exact same name and location again).
(Reporter)

Updated

16 years ago
Blocks: 154424

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 90734 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

16 years ago
Reopening for now, because it's not only the UI, butthe action fails as well.
Need to test to see, if that is gone as well.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Product: MailNews → Core

Updated

10 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Updated

9 years ago
QA Contact: meehansqa → networking.imap
To bug opener, do you still see problem you state in bug summary?
(Reporter)

Comment 10

8 years ago
How's that relevant? Please test yourself and stop asking that in all my bugs.
Please don't misunderstand my question. As you reffered UW-IMAP related issue which may be UW-IMAP specific in bug 567705, I'm checking UW-IMAP related bugs.
(Reporter)

Comment 12

8 years ago
Yes, I also said there that I don't use UW-IMAP myself anymore.
(In reply to comment #12)
> I also said there that I don't use UW-IMAP myself anymore.

Yah...

Ths bug is original of next problem?
> Bug 317597 uwimap IMAP Server - noselect folders not honored in folder list

See also next bugs.
> Bug 357911 Delete of IMAP mailbox fails for dual-use UW-imapd mailboxes (MIX folder)
> Bug 470350 Tbird cannot delete folder if it is currently open, and ignores IMAP error message (UW IMAP, MIX mailbox format)
Common phenomenon in delete cases is;
>    * LIST () "/" Mail/foo/
>    15 OK LIST completed
>    16 delete "Mail/foo/"
>    16 NO Can't lock mailbox for delete: Mail/foo/
Above is basically same phenomenon as as next bug.
> Bug 301714 subscribe, unsubscribe and delete add extra '/' to mailbox name
You need to log in before you can comment on or make changes to this bug.