[Fx4MobileLaunch] Implement new Firefox.com/m page

VERIFIED FIXED in 1.5

Status

P1
major
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: clooney, Assigned: jlong)

Tracking

Firefox 4
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pushed])

(Reporter)

Description

8 years ago
Firefox.com/m design is complete. Please implement for Firefox 4 for mobile GA (3/29)

From Jason:
Below is the finalized mockup:

http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/landing_P3_v3.png

Here is a mockup of the updated pull-down navigation as well. None of the text
has changed, just the look:

http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/pull_down_nav_P3.png
(Reporter)

Updated

8 years ago
Depends on: 634495
(Reporter)

Updated

8 years ago
Target Milestone: --- → 1.5

Comment 1

8 years ago
Hey James - this is another change for Mobile launch day. Take a look at those two .pngs posted above and let us know if you need anything else to get started. Thanks!
Assignee: nobody → jlong
Summary: Implement new Firefox.com/m page → [Fx4MobileLaunch] Implement new Firefox.com/m page

Comment 2

8 years ago
Do we have PSDs or some other form of source files for James to work with?
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 3

8 years ago
Jason - can you help provide these?
Sure can! The PSD can be found at http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/mobile_mozcom_P3_v3.psd . You'll need to get the "Phone on a Cloud" graphic from Sean. CCing him so he knows ;)

Comment 5

8 years ago
spooky. I had just uploaded it when I got the CC!

BEHOLD:
mozilla.seanmartell.com/engagement/mocodotcom/home-illustration.eps
(Assignee)

Comment 6

8 years ago
Just to clarify -- all the menu items link to external sites, not pages that are supposed to be loaded as an item in the mobile page?
James: Good question! Yes, those are links to external sites:

Mozilla Firefox -> this page
Features -> http://www.mozilla.com/en-US/mobile/features/ (mobile browser features)
Desktop -> http://www.mozilla.com/en-US/firefox/ (desktop browser home page)
Add-ons -> addons.mozilla.org
Support -> support.mozilla.org
Visit Mozilla -> mozilla.org

If you have an android phone, you can checkout support.mozilla.org or addons.mozilla.org and this is should be the current behavior of those sites as well.
(Assignee)

Comment 8

8 years ago
Sean (or whoever is designing this):

The iPhone image in the PSD is a layer that has the background baked into it. Is there any way you can fix it so that the iPhone has a transparent background?

If not I can work with this, but it would be better to have a transparent background on the image. Thanks!
(Assignee)

Comment 9

8 years ago
Nevermind, I was able to fix it myself. Ignore me!

Comment 10

8 years ago
Hey hey!  vector file can be found here: http://mozilla.seanmartell.com/engagement/mocodotcom/home-illustration.eps

Enjoy!
(Assignee)

Comment 11

8 years ago
(In reply to comment #10)
> Hey hey!  vector file can be found here:
> http://mozilla.seanmartell.com/engagement/mocodotcom/home-illustration.eps
> 
> Enjoy!

Ah, I missed that before. Looks great, thanks! It doesn't have the firefox logo on it like the PSD does, so I'll just throw it on there myself I guess?

Updated

8 years ago
Priority: -- → P1

Comment 12

8 years ago
Sure, that'd be great, thanks!

Updated

8 years ago
Blocks: 644777
(Assignee)

Comment 13

8 years ago
Just an update -- I've implemented most of this page, just need to get the tab at the top working. I'll push what I have in the morning. 

One thing, how is the "other languages" supposed to work? Where do I get a list of languages? When it switches it just tries to switch locales?
(Reporter)

Comment 14

8 years ago
Slater - what's the deal with other languages for desktop?
http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/landing_P3_v3.png
James - The design is like mozilla.com, where when you select a language in the footer, it tries to switch locales (if I understand that terminology correctly). There's an "Other Languages" box on mozilla.com right now, so I'd think you could get the list from there, but if that's hard-coded or otherwise difficult to extract, then I say the "Other Languages" feature seems like something that can wait until next quarter.
(Assignee)

Comment 16

8 years ago
initial implementation in r86385

http://www-trunk.stage.mozilla.com/en-US/m

There are still a few tweaks and I need to fill most of the links, should be easy. But I need to go ahead and commit this to get any other feedback.
(Assignee)

Comment 17

8 years ago
(In reply to comment #15)
> James - The design is like mozilla.com, where when you select a language in the
> footer, it tries to switch locales (if I understand that terminology
> correctly). There's an "Other Languages" box on mozilla.com right now, so I'd
> think you could get the list from there, but if that's hard-coded or otherwise
> difficult to extract, then I say the "Other Languages" feature seems like
> something that can wait until next quarter.

Ok, it looks like it's easy to get the select, but I would need to look into how to switch locales. I'm going to work on other bugs for now and we'll see if we can make that work.

Comment 18

8 years ago
(In reply to comment #16)
> initial implementation in r86385
> 
> http://www-trunk.stage.mozilla.com/en-US/m
> 
> There are still a few tweaks and I need to fill most of the links, should be
> easy. But I need to go ahead and commit this to get any other feedback.

Pascal is going to get firefox.com/m localized in all the languages that are being localized for the Android Marketplace. Unfortunately, though, b/c of timing the l10n versions will be using the older design rather than Jason's slick new one. We'll move to the new design in the locales after the launch.

Comment 19

8 years ago
Sorry, the above was supposed to be a response to comment #14 rather than comment #16.
(Assignee)

Comment 20

8 years ago
fixes pushed in r86407
(Assignee)

Comment 21

8 years ago
what's the link to the privacy policy and release notes?
(Assignee)

Updated

8 years ago
Keywords: qawanted
(Assignee)

Comment 22

8 years ago
fixed broken links in r86419

Comment 23

8 years ago
(In reply to comment #21)
> what's the link to the privacy policy and release notes?

PP:
http://www.mozilla.com/en-US/m/privacy.html

Release Notes: 
http://www.mozilla.com/mobile/4.0/releasenotes/
(Reporter)

Comment 24

8 years ago
yes.
The privacy policy link is still missing
Keywords: qawanted
(Assignee)

Comment 26

8 years ago
added priv pol in r86634

are you testing on several phones?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: qawanted
Resolution: --- → FIXED
qa-verified-trunk https://www-trunk.stage.mozilla.com/en-US/m/

testing on HTC Desire. For other phones I use the UA Switcher addon
Keywords: qawanted
(Assignee)

Comment 28

8 years ago
I found some menu problems, at least on my iPhone. The top of the page was cut off (firefox logo and menu button). I changed the way the menu works, which relies on some javascript magic at page load. It's not my favorite solution but it's the only way to have the CSS sliding animation cross-browser.

Sorry Raymond, but please test again, just the menu this time (see if it slides open).

done in r86640
Keywords: qawanted
(Assignee)

Updated

8 years ago
Duplicate of this bug: 645774
(Assignee)

Comment 30

8 years ago
fixed links mentioned in bug 645774, features and FAQ link now point to appropriate mobile-version of pages

in r86641
(Assignee)

Comment 31

8 years ago
Verdi reported a problem with the nav, so I'm disabling the animation for now. There was some hacks to get the sliding effect, but we can fix that later.

done in r86656
(Assignee)

Comment 32

8 years ago
pushed to stage r86661
(Assignee)

Updated

8 years ago
Whiteboard: [pushed]
(Assignee)

Comment 33

8 years ago
fixed spark link in r86705
pushed to stage r86706
(Assignee)

Comment 34

8 years ago
fixed locale switcher on en-US page in r86707
(Assignee)

Comment 35

8 years ago
push to stage r86708
(Assignee)

Comment 36

8 years ago
argh. added the wurfl library back in (removed because it didn't work locally). 

trunk r86709
stage r86710
(Assignee)

Comment 37

8 years ago
argh again. testing seems to indicate problems with the wurfl library, and we've been testing without it, so leaving it off for now.

trunk r86711
stage r86712
qa-verified-stage https://www.stage.mozilla.com/en-US/m/
Keywords: qawanted
verified fixed http://www.mozilla.com/en-US/m/ using HTC Incredible
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.