Change of window size in one tab effects all the other tabs

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: t8av, Unassigned)

Tracking

3.6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-07-20])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.15) Gecko/20110303 BTRS28059 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.15) Gecko/20110303 BTRS28059 Firefox/3.6.15

When few tabs are open, if in one tab surfing a website which changed the size of the window/frame - all the tabs are effected.

Reproducible: Always

Steps to Reproduce:
1. Open few tabs with different websites.

2. In one of the tabs go to a website which changes the size of the window, such as the Korean website: http://minihp.cyworld.com/pims/main/pims_main.asp?tid=30461266&list_type=2&urlstr=video&board_no=65&seq=65&item_seq=65349529&item_seq_main=65349529&folder_part=3

Actual Results:  
The size of the entire firefox window changes (in the above example, it becomes smaller)

Expected Results:  
The window size of firefox should not be effected. Only the specific tab should be effected but of course its overall size should not change.
Should be fixed by Bug 565541.

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 2

6 years ago
I know this is 2 years old now but we have open defects on 2011-10-08 relating to resize and move to weorking on FFirefox 7.0.1 even with Advanced Javascript settings set to ALLOW move and resize.

Of course if you are using multiple tabs, and a script in a page in one tab resizes the window, the whole window, and all the tabs, are resized. If you want them to have different sizes, have multiple one-tab windows, not one multi-tab window!! This is working as designed, not a defect.

I use a local file page to resize windows. SOmetimes I want to resize to exactly half my screen a window that already has a (remote) web page displayed; rather than forcing a reload after, I open a second tab with my resize script, then close that tab. My remote page is now in a neatly resized window.

Comment 3

5 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #1)
> Should be fixed by Bug 565541.

t8av, since 2011-05-12 have you seen this problem again?
Flags: needinfo?(t8av)
Whiteboard: [closeme 2013-07-20]
(Reporter)

Comment 4

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #3)
> (In reply to XtC4UaLL [:xtc4uall] from comment #1)
> > Should be fixed by Bug 565541.
> 
> t8av, since 2011-05-12 have you seen this problem again?

No, you can close this bug.
Flags: needinfo?(t8av)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.