Closed Bug 642363 Opened 12 years ago Closed 10 years ago

configure extremely slow on Win 7 + VS2010

Categories

(Firefox Build System :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 632344

People

(Reporter: Dolske, Unassigned)

Details

I was doing some build benchmarking on my new Macbook Pro (running Windows 7 + VS2010 + current MozillaBuild), and noticed that running configure for the first time takes forever -- 7 to 8 minutes. [Which is a bit crazy, because a full pymake -j12 build takes ~15 minutes.]

This mostly seems to be due to pauses at 3 points, where the console output is at:

checking for atlbase.h...
checking for d3d9.h...
checking for d3d10.h...

I didn't time exactly, but each of the first two seem to get stuck for 1-2 minues, and the d3d10.h one seems to take even longer. The rest of the configure output scrolls by quite rapidly.

Nothing interesting in config.log at these points.
I was going to suggest that this is probably a dupe of that bug, but that just ought to fix the slowest parts. configure is still slow on windows.
Yeah, I think we can resolve this a dup.
So let's resolve as a dupe!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.