[SUMO] Problem with text versions for Android+Maemo

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: thomas.lendo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Since a while, choosing an Android or Maemo version of an article shows the Windows version of the text. You can test this behavior at https://support.mozilla.com/en-US/kb/templateopen-add-ons. There is no difference in the shown text for Android/Maemo and Windows.

This has disadvantages if you are using extra text for Firefox Mobile which doesn't work anymore.

At https://support.mozilla.com/de/kb/Template:optionspreferences/revision/10331#os=win&browser=fx4 you can see another weird behavior.
When using a FOR NOT/FOR to separate non-Android and Android text versions, only the Android version will be shown. Some days before when I made this changes for Android (20.02.2011) all works very well and I was happy because of this cool FOR feature. Now this doesn't work anymore.
(Reporter)

Comment 1

8 years ago
Another example at page https://support.mozilla.com/de/kb/Template:aboutconfig#os=mac&browser=fx4

I added the mobile versions in the source code:
{for win,linux,android,maemo}die {key Eingabetaste}{/for}{for mac}{key Return}{/for}

At the time I made this change all works well, but now {key Eingabetaste} is always shown - regardless what OS I'm choosing.
We've had some recent showfor changes in bug 638127, which affects the behavior of desktop VS mobile content. Does that clear things up?
Keywords: regression
Specifically, this was an intentional change in bug 638127, not a regression.

Maybe Kadir or Michael can help reword or work around this?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: regression
Resolution: --- → WONTFIX
(Reporter)

Comment 4

8 years ago
James, thanks. We've corrected it and now it's in sync with the English version again.
You need to log in before you can comment on or make changes to this bug.