Last Comment Bug 642423 - Bookmarks Toolbar tool tips appear when they should not
: Bookmarks Toolbar tool tips appear when they should not
Status: VERIFIED FIXED
[fixed by bug 596600]
: regression
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: unspecified
: All Mac OS X
: -- normal (vote)
: Firefox 6
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 649222 (view as bug list)
Depends on: 596600
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 05:42 PDT by Andre Bach
Modified: 2011-05-20 06:27 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andre Bach 2011-03-17 05:42:41 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

On Mac OS X with the Firefox 4 RC, the tool tip (or title text) that appears when hovering over items in the bookmarks toolbar will incorrectly appear, and stay permanently, when switching from Firefox to another application, or when Firefox is in the background. It looks like Firefox is getting the 'cursor is on top of the bookmark' message but not the 'cursor had moved off the bookmark' message, so the tip/text appears and doesn't go away until you do some gymnastics with the mouse. It's very annoying.

Could be fixed, I hope, by disabling the drawing of these tool tips whenever Firefox is not the foreground application.

Reproducible: Always

Steps to Reproduce:
1. Let a Firefox 4 window, with bookmarks toolbar enabled, be open and visible in the background.
2. With any other application active, move the cursor at medium-slow speed over one of the bookmarks.
3. Pause for, I don't know, 0.2 seconds over the bookmark so it gets the grey coloring, then move off before the tool tip appears.
4. [Alternatively, move the cursor to a bookmark when Firefox is active, then command-tab to any other application and move the mouse away.]
Actual Results:  
A fraction of a second after moving the cursor away, the tool tip will appear by the bookmark in the background window. Then it will stay there forever! Or until you move the cursor back to the vicinity.

Expected Results:  
There should be not tooltips at all in either of these scenarios.

Appeared in one of the Firefox 4 betas, and continues to be constant bug in the RC.
Comment 1 Andre Bach 2011-03-25 08:23:17 PDT
Still in final 4.0 version.
Comment 2 Thomas Ahlblom 2011-04-11 20:43:10 PDT
*** Bug 649222 has been marked as a duplicate of this bug. ***
Comment 3 Andre Bach 2011-04-12 03:47:47 PDT
Well, at least I know it's not just me. :)  Any chance someone will take a look at this? I'm just a user, so I don't know anything to do to fix it...
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-04-12 05:55:01 PDT
confirming per duplicate.

If you could help finding the regression window (so, at which beta, and more specifically at which nightly, it started) would be useful.
This tool could come to hand: http://harthur.github.com/mozregression/
Comment 5 Ben Perkins 2011-04-12 07:26:27 PDT
Thank you for the steps, they are reproducible every time unlike mine. It should also be noted that after this occurs, every bookmark bar tool tip appears in that same location (on my computer at least). I will begin trying to use mozregression to see if I can pinpoint the build that it happen (I believe I remember it from some early beta builds)
Comment 6 Ben Perkins 2011-04-12 07:56:19 PDT
The bug appeared first in the build from 2010 8/28.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-04-12 08:07:13 PDT
based on comment 6, the regwindow should be
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1d55bbd1d1d&tochange=6e3f6d18c124
Comment 8 Andre Bach 2011-04-12 11:00:59 PDT
I can confirm that regression, and add one piece of information: The strip that appears the first time the browser appears (about "know your rights") affects the bug. If the strip is still there, it's much harder to get the bad popups to stay. The steps to reproduce work if the know-your-rights-bar is dismissed first.
Comment 9 Markus Stange [:mstange] 2011-04-12 11:36:53 PDT
This was caused by bug 130078 and will be fixed by the patch in bug 596600 (which unfortunately missed the Firefox 5 cutoff, my bad).
Comment 10 Ben Perkins 2011-04-12 11:52:43 PDT
Firefox 5 or 4 cutoff? Sorry I don't understand how the release schedule works, but do you know when we might expect to see this patch?
Comment 11 Markus Stange [:mstange] 2011-04-12 12:02:38 PDT
Firefox 5 cutoff. The fix will be in Firefox 6, which will probably be released around August 2nd, 2011, according to current planning (see "Schedule of Important Milestones" on http://mozilla.github.com/process-releases/draft/development_specifics/ ).
Comment 12 Ben Perkins 2011-04-12 15:21:00 PDT
Hmm, ok. Until then if it really bugs anyone else, you can work around this issue by going to about:config and setting "browser.chrome.toolbar_tips" to false. Not the best work-around, but it gets the job done.
Comment 13 godzfire 2011-05-15 11:02:15 PDT
Just an FYI. This problem is also a nasty issue in SeaMonkey and personally driving me nuts.

Here's the thread I created with a write up and pictures:
http://forums.mozillazine.org/viewtopic.php?f=5&t=2125451
Comment 14 Markus Stange [:mstange] 2011-05-16 12:04:26 PDT
Fixed by bug 596600.
Comment 15 John Hawkinson 2011-05-20 00:37:17 PDT
I hope this comment is in scope, but I am not sure.

I see bookmark tooltips under MacOS 10.6.7 when Adobe InDesign is the active application and the mouse is over a Firefox bookmark, even when there is an InDesign window (panel, but not main document) on top of Firefox.

I believe that matches the conditions for bug 649222, which is duped into this bug ("Bookmark bar tooltips often displayed incorrectly when Firefox is not focused").

The 596600 patch does *not* fix this problem. I see the problem with a checkout on the nightly trunk from just now (http://hg.mozilla.org/mozilla-central/rev/2e0e36b0feae).

I feel like this may also related to Bug 148624 ("Tooltips persist in foreground when Mozilla is in background") though no one claims to have fixed that -- it is quite similar to this one though.

What steps, if any, should I take?
Comment 16 Markus Stange [:mstange] 2011-05-20 03:40:06 PDT
John, I've filed bug 658500 with a patch for your problem.
Comment 17 George Carstoiu 2011-05-20 06:27:57 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110519 Firefox/6.0a1

Verified using steps from Comment 0, on Mac OS X 10.6 - issue is no longer present, the tool-tip disappears when mouse changes position.

Note You need to log in before you can comment on or make changes to this bug.