Last Comment Bug 642444 - Document compartment methods on MDC
: Document compartment methods on MDC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
https://developer.mozilla.org/en/Spid...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 07:15 PDT by Shawn Wilsher :sdwilsh
Modified: 2012-07-21 15:29 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Shawn Wilsher :sdwilsh 2011-03-17 07:15:42 PDT
It would be a huge help if someone could go and document the various compartment methods on MDC like:
JS_NewCompartmentAndGlobalObject
JS_LeaveCrossCompartmentCall
JS_EnterCrossCompartmentCall
Comment 1 David Mandelin [:dmandelin] 2011-03-21 18:33:39 PDT
I started this on the main JSAPI reference page, in the "Runtimes and Contexts" section, under a "Compartments" subheader. The API docs I just wrote seem kind of terse and hard to understand without some kind of introduction to compartments.

Anyway, let me know what you think, whether it's at all useful yet, what else might need to be said, and what questions are left unanswered.
Comment 2 Till Schneidereit [:till] 2012-07-21 15:29:23 PDT
These have since been documented.

Note You need to log in before you can comment on or make changes to this bug.