Add caching of hostnames used by sites, for DNS pre-resolution

RESOLVED DUPLICATE of bug 580104

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 580104
7 years ago
7 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome] [parity-ie])

(Reporter)

Description

7 years ago
IE9 does this, and I believe Chrome has been doing so for some time.

See "Speculative Pre-resolution for Visited Sites" at

http://blogs.msdn.com/b/ie/archive/2011/03/17/internet-explorer-9-network-performance-improvements.aspx

The basic idea is: Along with a history entry, store a list of the hostnames it looked up last time you loaded it.  Now when you go to load it again, fire off DNS requests for all those hostnames immediately.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580104
You need to log in before you can comment on or make changes to this bug.