Eagerly open a second connection to servers

RESOLVED DUPLICATE of bug 634278

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 634278
7 years ago
6 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I thought this was a cute trick, in the "Faster Networking through Parallelism" section of [1].

"Virtually all sites end up using more than one HTTP connection per hostname, and time could be saved if we open a second 'background' connection when establishing the first connection. This background connection is available for the next HTTP request without forcing it to wait for the original connection to become available, and without the delay of opening a new connection in a 'just in time' manner. Only one background connection is opened per host."

I think this is worth investigating.

AIUI, Chrome does something similar, although for a different reason.  My understanding is that it sends two SYNs when opening a connection, because loss of a SYN triggers a long TCP timeout.

It seems that we could combine these two approaches (and indeed Chrome may already be doing this).  Send two SYNs to try to open two connections.  And if one of the SYNs doesn't get there, then no problem.

 http://blogs.msdn.com/b/ie/archive/2011/03/17/internet-explorer-9-network-performance-improvements.aspx
Bug 634278 is already on file for this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634278
You need to log in before you can comment on or make changes to this bug.