NSS users should not include cdbhdl.h.

RESOLVED FIXED in 3.2

Status

NSS
Libraries
P1
major
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Robert Relyea)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Some NSS users have had to include the
internal NSS header cdbhdl.h so that they
can allocate a CERTCertDBHandle structure
and pass its address to the cert database
open functions such as CERT_OpenCertDB(),
CERT_OpenCertDBFilename(), and
CERT_OpenVolatileCertDB().

The reason why these NSS users have to call
the cert db open functions directly is that 
the preferred method of using NSS_Init()
doesn't support the naming convention in use
by these NSS users.  Two possible solutions are:
1) Change the cert db open calls to allocate and
return the handle (as is done in the key db interface) -or-
2) Add calls to similar to NSS_Init() that allow the
NSS users to use the current naming convention without
making direct calls to the cert db open interface.

This issue must be resolved before we release
NSS 3.2 Beta.
(Reporter)

Updated

17 years ago
Priority: -- → P1
Target Milestone: --- → 3.2
(Reporter)

Updated

17 years ago
Severity: blocker → major
(Reporter)

Comment 1

17 years ago
Turns out that we have previously agreed to implement
solution #2.
(Reporter)

Comment 2

17 years ago
Bob has written the new NSS_Initialize() function.
I think we can mark this bug fixed.
Assignee: kirke → relyea
(Reporter)

Comment 3

17 years ago
*** Bug 56330 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
Created attachment 23881 [details] [diff] [review]
remove depricated header function
(Assignee)

Comment 5

17 years ago
Here are the 'last' of the cmd files which included the header (dbck.c was not
changed because it isn't compiled, but is an internal tool that does need this
private header).
Status: NEW → ASSIGNED
(Reporter)

Comment 6

17 years ago
The patch is good.

Bob, should we move cdbhdl.h from EXPORTS to PRIVATE_EXPORTS?
Does any of our client (such as PSM or JSS) need it?
(Reporter)

Comment 7

17 years ago
Do we need to worry about instinit and newuser?

Comment 8

17 years ago
JSS still uses this header file, but we can still get at it if it is a 
PRIVATE_EXPORT.
(Assignee)

Comment 9

17 years ago
Created attachment 24104 [details] [diff] [review]
remove cdbhdl.h from instinit and newuser
(Reporter)

Comment 10

17 years ago
This patch is good.
(Assignee)

Comment 11

17 years ago
Created attachment 24830 [details] [diff] [review]
Final piece, move cdbhdl.h to the private exports list.
(Reporter)

Comment 12

17 years ago
Amen.
(Assignee)

Comment 13

17 years ago
cdbhdl.h is now on the private exports list.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.