The new statistics page is really resource hungry

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: fiotakis, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre
Build Identifier: 

While checking the localization of the new download statistics page, I noticed that the heat went really high on both my laptops.
Laptop nr1 is not what I'd call a high-end machine (Toshiba Satellite M305 -CPU  T3400, Mobile 4 Series Chipset Integrated Graphics, running fedora 14 with webGL enabled).
The other one though is a pretty strong machine (HP pavilion dv7 - CPU i7, NVidia GeForce 230M with hardware acceleration enabled both on windows 7 and ubuntu 10.10).
Same results on both machines, while I focus on the glow.allizom.org tab the heat goes up to 70+ degrees.

Reproducible: Always
I have turned off my heater and visit this page whenever my room gets cold.

However, that's how it's going to be. It's pretty expensive for the browser to repaint the screen, and we're forcing it to repaint a whole lot. I think we've done pretty well at optimizing our loops in javascript; most of the cpu cycles are spent in the browser. When I turn off the parts of our code that force repaints I go from 90% CPU to around 10%.

We have to crank up the CPU to achieve the visual experience on this site. I'll be excited if someone sees this site and can tell us how to make our code go faster or make the browser go faster.

Thanks for filing a bug, and thanks for localizing!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

8 years ago
Well, perhaps we shouldn't publish that page then, or at least not publish it along with the release, since it's going to make users feel uncomfortable with their brand new browser(?)
You need to log in before you can comment on or make changes to this bug.