Last Comment Bug 642721 - _cairo_d2d_mask reads uninitialized memory
: _cairo_d2d_mask reads uninitialized memory
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 600760
  Show dependency treegraph
 
Reported: 2011-03-17 21:23 PDT by Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
Modified: 2011-04-26 13:26 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.35 KB, patch)
2011-03-17 21:23 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
no flags Details | Diff | Review

Description Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-03-17 21:23:00 PDT
When 'clip' is NULL, we reach

       box.p1.x = MAX(box.p1.x, boxes->p1.x);
       box.p2.x = MIN(box.p2.x, boxes->p2.x);
       box.p1.y = MAX(box.p1.y, boxes->p1.y);
       box.p2.y = MIN(box.p2.y, boxes->p2.y);

with 'boxes' set to &box_stack, which is uninitialized on the stack. We seem to be getting lucky most of the time and these operations are having no effect, but with some patches in my queue, we stop getting lucky and reftests start failing :-(.
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-03-17 21:23:42 PDT
Created attachment 520126 [details] [diff] [review]
fix
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-03-17 21:27:21 PDT
correction, test_canvas.html starts failing.
Comment 3 Bas Schouten (:bas.schouten) 2011-03-18 04:51:20 PDT
This is certainly an improvement!

We're not getting lucky most of the time however, and I could r+ this, however the code you're fixing is from the unreviewed patch from bug 600760 :). In other words it's not being tested (it's not even present) at the moment and that's probably the only reason the test doesn't fail without your patch queue, since that patch is in your patch queue.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-03-18 05:43:13 PDT
Aha! Well then, feel free to roll this into bug 600760.
Comment 5 Bas Schouten (:bas.schouten) 2011-03-18 17:42:31 PDT
(In reply to comment #4)
> Aha! Well then, feel free to roll this into bug 600760.

Will do! Thanks for catching this. I hope it didn't cause too much trouble.
Comment 6 Bas Schouten (:bas.schouten) 2011-04-26 13:26:11 PDT
Comment on attachment 520126 [details] [diff] [review]
fix

This was fixed in the original patch this bug was in.

Note You need to log in before you can comment on or make changes to this bug.