If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Path to Local Folders is wrong

RESOLVED WORKSFORME

Status

Thunderbird
Preferences
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Jim Reisert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110314 Thunderbird/3.3a3

Tools | Account Settings | Local Folders

My local folders path is F:\Thunderbird\Local Folders

In the account manager it appears as:

  C:\F:\Thunderbird\Local Folders

I have tried changing the path to F:\ and it still shows above.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 520191 [details]
screen capture of account options
does it also happens if you start Thunderbird in -safe-mode ? (http://support.mozillamessaging.com/en-US/kb/Safe+Mode)

Comment 3

7 years ago
Can you go into the Config Editor (Tools > Options > Advanced > General tab) and look at the following preferences:

  mail.accountmanager.localfoldersserver (should be "server1")
  mail.server.server1.directory      (should be "F:\Thunderbird\Local Folders")
  mail.server.server1.directory-rel  (that's a relative path to that location)

There have been reports (e.g., bug 627391) with issues representing the drive letter in the relative path, so this may be a related problem.
(Reporter)

Comment 4

7 years ago
RE: -safe-mode

I will try from home tonight.

RE: options

I have both Thunderbird 3.1 and Miramar 3.3 installed.  When I ran Tbird, I saw the same C:\F:\Thunderbird\... in the path.  I changed it in Tbird, and it stayed changed.  But I didn't go back and check what Miramar now saw.  I have NEVER changed this setting in Miramar until today, but it hasn't been broken as far as I know.  I'll open Miramar tonight to see what the path changed to (by Tbird).
(Reporter)

Comment 5

7 years ago
I just peeked at bug 627391 and saw this line:

"I think a contributing issue may be that your signature is on a different drive
than the Thunderbird profile."

My profile is on C:\ and my local folder is on F:\
(Reporter)

Comment 6

7 years ago
Tbird:

  mail.accountmanager.localfoldersserver  "server2"
  mail.server.server2.directory           "F:\Thunderbird\Local Folders"
  mail.server.server2.directory-rel

        "[ProfD]../../../../../../../../F:/Thunderbird/Local Folders"

Remember, this is from when I ran Thunderbird 3.1

Settings look exactly the same in Miramar.  Local folder displays correctly.

Now I changed the local directory to D:\Home and local folders still looks correct.

I wonder if a prior Alpha of Miramar could have caused this, and I didn't notice it until today?

Anyway, I think you can close this, as I can't repeat it since changing the path in Thunderbird.

Comment 7

7 years ago
Closing this bug based on comment #6, it's a bit irritating though anyway.
Feel free to reopen this report if it's reproducible at a later time again.

While relative paths are certainly useful in some environment around the current working folder, I'm wondering if it makes sense to still produce a relative path eight levels down from the profile location, especially if the target is located on a different drive. Maybe it makes sense to restrict when ".directory-rel" is created or used to the number of levels to avoid possible inconsistencies, but this is likely something that would need to be addressed in Core or Toolkit code (thus beyond Thunderbird's scope itself).

-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.