Closed Bug 642896 Opened 9 years ago Closed 9 years ago

Fatal assert in resetInvokeCallFrame running Firebug tests

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: luke)

References

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(2 files)

Steps to reproduce are in bug 642801 comment 0.

The assert fails because flags_ contains JSFRAME_HAS_HOOK_DATA.

Luke, what's this assert asserting?  Should JSFRAME_HAS_HOOK_DATA just be added to it?
You're right, its missing.  The original reason the flag was omitted was that InvokeSessionGuard didn't take the optimized path during debug mode, but that restriction has since been removed.
Attached patch fixSplinter Review
Assignee: general → luke
Status: NEW → ASSIGNED
Attachment #520704 - Flags: review?(jwalden+bmo)
Attachment #520704 - Flags: review?(jwalden+bmo) → review+
http://hg.mozilla.org/tracemonkey/rev/d8940239b347
Whiteboard: fixed-in-tracemonkey
Attached patch Fix the assert.Splinter Review
Attachment #520710 - Flags: review?(luke)
Attachment #520710 - Flags: review?(luke)
http://hg.mozilla.org/mozilla-central/rev/d8940239b347
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.