Last Comment Bug 643112 - IPC not building on Linux PPC
: IPC not building on Linux PPC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: PowerPC Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 579757 587188 (view as bug list)
Depends on:
Blocks: 563747
  Show dependency treegraph
 
Reported: 2011-03-19 03:24 PDT by Mike Hommey [:glandium]
Modified: 2011-07-08 20:59 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix IPC for Linux PPC (702 bytes, patch)
2011-03-19 03:24 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Review
Fix IPC for Linux PPC (1.14 KB, patch)
2011-03-19 13:01 PDT, Mike Hommey [:glandium]
benjamin: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-03-19 03:24:23 PDT
Created attachment 520425 [details] [diff] [review]
Fix IPC for Linux PPC

Build ends with:
../../../ipc/chromium/src/build/build_config.h:64:2: error: #error Please add support for your architecture in build/build_config.h

This is because __ppc__ isn't defined by gcc on linux, while e.g. __powerpc__ is.
Comment 1 Mike Hommey [:glandium] 2011-03-19 12:30:31 PDT
Interestingly, I now get this:
ipc/chromium/src/base/data_pack.cc:96:3: error: size of array 'datapack_assumes_little_endian' is negative

I guess whenever the mac ppc support was added, this wasn't there...
Comment 2 Mike Hommey [:glandium] 2011-03-19 12:41:17 PDT
(In reply to comment #1)
> Interestingly, I now get this:
> ipc/chromium/src/base/data_pack.cc:96:3: error: size of array
> 'datapack_assumes_little_endian' is negative
> 
> I guess whenever the mac ppc support was added, this wasn't there...

Simpler: data_pack.cc is not used on mac.
Comment 3 Mike Hommey [:glandium] 2011-03-19 13:01:46 PDT
Created attachment 520465 [details] [diff] [review]
Fix IPC for Linux PPC

It turns out nothing uses DataPack, so we can just build without it.
Comment 4 Mike Hommey [:glandium] 2011-04-13 01:12:55 PDT
http://hg.mozilla.org/mozilla-central/rev/b0df2e9b1489
Comment 5 Wolfgang Rosenauer [:wolfiR] 2011-05-03 22:02:15 PDT
*** Bug 587188 has been marked as a duplicate of this bug. ***
Comment 6 Cameron Kaiser [:spectre] 2011-07-08 20:59:50 PDT
*** Bug 579757 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.