Tab management is screwed when browser.ctrlTab.previews is set to TRUE

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: siddharth.813, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I entered about:config in Firefox 4 and set 
browser.ctrlTab.previews to true.

Now when I try to go to the next tab by using Ctrl+Tab, it works more like Alt+Tab between windows.

For example, if I go from tab 10 to tab 1 and if I use Ctrl+Tab, I should be navigated to tab 2 and not tab 10. Moreover it switches between the tab groups. You get what I mean?
Group 1 tab 2 -> Ctrl+Tab -> Group 2 tab 2 -> Ctrl+Tab -> Group 1 tab 2...

It should be more like Group 1 tab 2 -> Ctrl+Tab -> Group 1 tab 3 

OR

It should be more like Group 1 tab 2 -> Ctrl+Tab -> Group 1 tab 1.

Hey guys at Mozilla, you are getting the basics wrong. Firefox 4 is a really good product but don't lose more people. I am a fresh graduate. There are simple ways to solve the tab problem.
Please don't screw your APIs.

I write for http://hacktivist.tumblr.com/ and for http://fastestfox.wordpress.com/ and I love Firefox. I have seen people struggling to do simple tasks. Please hire a good user experience engineer.

One more huge problem that FF4 users are facing is that when they save and quit, they have to sort their tabs into groups again. Why? Can't you think of a simple solution?

Group 1: Tab 1, Tab 2...
Group 2: Tab a, Tab b...

Pinned tab x, Pinned tab y...

Save and quit. When restored, restore the tab and the group that was closed. Simple as that guys. I can find hundreds of ways to make this product better but I have a job to find and in the little time I get to test FF4, I find a hundred mistakes.

Guys, somethings in life have very simple solutions. Find them.
Sorry if I vented. I don't want to see Firefox the next Netscape.

Reproducible: Always

Steps to Reproduce:
1.Set browser.ctrlTab.previews to true.
2. Open few tabs like 10. Go from 10th tab to any tab like tab 6
3. Press Ctrl + Tab


Expected Results:  
Simple. Gone to the next tab.
browser.ctrlTab.previews is as of now unsupported (thus "false" by default) and not designed (yet?) to work correcty with Regard to Tabcandy/Panorama.

Please file a separate Report for the (or any) other Issue against the proper Component.

Further you can drop any "if you don't do this, .... then xxx happens" and/or non-technical Stuff when filing Reports. File them to the Point and keep it in perspective.
(In reply to comment #1)
> not designed (yet?) to work correcty with Regard to Tabcandy/Panorama.

That's not true.

If I understand the reporter, he wants browser.ctrlTab.previews = true to use same tab order as browser.ctrlTab.previews = false. That's not how it's supposed to work.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

2 years ago
Duplicate of this bug: 1277561
You need to log in before you can comment on or make changes to this bug.