When 'load images automatically' is unchecked, images still load on google images

RESOLVED DUPLICATE of bug 331257

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 331257
7 years ago
7 years ago

People

(Reporter: jake pa, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

When 'load images automatically' is unchecked, images still load on google images (for all other sites I have tried, images seem to correctly remain unloaded). I have tried clearing the cache and restarting firefox, but nothing seems to prevent images from loading in google. For example, try:

http://www.google.com/images?q=torn+pectoral+muscle&hl=en&safe=off&client=firefox-a&hs=uyz&rls=org.mozilla:en-US:official&prmd=ivns&source=lnms&tbs=isch:1&ei=Y9uETdH3D4GgsQOusvHrAQ&sa=X&oi=mode_link&ct=mode&cd=2&ved=0CAcQ_AUoAQ&biw=1391&bih=797

I want to make the browser 100% p0rn-safe, and hoped that disabling images would do it. Is there something else I need to set or can configure in about: ? Many thanks!

Reproducible: Always

Steps to Reproduce:
1. Uncheck 'load images automatically' in preferences -> content
2. Go to http://www.google.com/images?q=torn+pectoral+muscle&hl=en&safe=off&client=firefox-a&hs=uyz&rls=org.mozilla:en-US:official&prmd=ivns&source=lnms&tbs=isch:1&ei=Y9uETdH3D4GgsQOusvHrAQ&sa=X&oi=mode_link&ct=mode&cd=2&ved=0CAcQ_AUoAQ&biw=1391&bih=797
3. All the images still display!
Actual Results:  
All images still display

Expected Results:  
No images should display.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
The images are gone for me with FF3.6.15 but it's known that google sometimes uses data: inside the html instead of image URLs. I assume that you get data images
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331257
You need to log in before you can comment on or make changes to this bug.