Firefox crashes every time launched or opened. [@ js_ExecuteRegExp]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: unpitt23, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 (.NET CLR 3.5.30729)

I think it is due to an extension or another program on computer since it works in safe mode.  I try to open up firefox and firefox window appears but as soon as I try to do anything it crashed within a few moments.

Reproducible: Always

Steps to Reproduce:
1.  I just need to try to start firefox.
2.
3.
Actual Results:  
Firefox crashes.

Expected Results:  
It should have opened and stayed open.

Firefox 3.6.15 Crash Report [@ js_ExecuteRegExp ]

ID: 38cbcfc7-ad2c-4f8d-bf68-bbcc42110318
Signature: js_ExecuteRegExp



Extension 	Extension Id 	Version 	Current?
	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} 	1.3.3 	
	elemhidehelper@adblockplus.org 	1.1.1 	
All-in-One Sidebar 	{097d3191-e6fa-4728-9826-b533d755359d} 	0.7.13 	current
	autofillForms@blueimp.net 	0.9.8.0 	
	{d40f5e7b-d2cf-4856-b441-cc613eeffbe3} 	1.49 	
	CLEO@guid.customsoftwareconsult.com 	4.3 	
	{0545b830-f0aa-4d7e-8820-50a4629a56fe} 	4.6.5 	
	{8B72860F-C5F8-4286-865E-D2C2DB98A9E6} 	1.0.0 	
	piclens@cooliris.com 	1.12.2.44026 	
	custombuttons@xsms.org 	0.0.5.3 	
	CustomButtons2@cbtnext.org 	3.1.0 	
	{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389} 	0.9.8 	
	{b9db16a4-6edc-47ec-a1f4-b86292ed211d} 	4.8.4 	
	{DDC359D1-844A-42a7-9AA1-88A850A938A8} 	2.0.2 	
	{c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} 	4.0 	
	{c50ca3c4-5656-43c2-a061-13e717f73fc8} 	4.0.1 	
	{472f4ef0-a825-11da-a746-0800200c9a66} 	1.2 	
	{4BBDD651-70CF-4821-84F8-2B918CF89CA3} 	6.3.3.2 	
	fireform@mozilla.org 	0.7.4 	
	{0b457cAA-602d-484a-8fe7-c1d894a011ba} 	0.88 	
	{1018e4d6-728f-4b20-ad56-37578a4de76b} 	4.1.1 	
	max@subfighter.com 	1.0.3 	
FlashGot 	{19503e42-ca3c-4c27-b1e2-9cdb2170ee34} 	1.2.8.4 	current
	{3CE993BF-A3D9-4fd2-B3B6-768CBBC337F8} 	0.9.6 	
FoxClocks 	{d37dc5d0-431d-44e5-8c91-49419370caa1} 	2.6.18 	current
Greasemonkey 	{e4a8a97b-f2ed-450b-b12d-ee082ba24781} 	0.9.1 	current
	user@imagiris.txt 	1.2 	
	{9AA46F4F-4DC7-4c06-97AF-5035170634FE} 	4.0 	
	{c33c5b47-69c8-45a4-a5e0-af85bbe628dd} 	1.6.1.3 	
	jqs@sun.com 	1.0 	
	support@lastpass.com 	1.73.0 	
	lazarus@interclue.com 	2.0.5 	
	{75CEEE46-9B64-46f8-94BF-54012DE155F0} 	0.4.6 	
	moveplayer@movenetworks.com 	7 	
	{9669CC8F-B388-42FE-86F4-CB5E7F5A8BDC} 	6.0.4 	
	netvideohunter@netvideohunter.com 	1.7 	
	OPIE@guid.customsoftwareconsult.com 	1.2.3 	
	orbit_ffext@orbitdownloader 	2.02 	
	{35106bca-6c78-48c7-ac28-56df30b51d2c} 	0.6.4 	
	outwit-docs@outwit.com 	0.3.3.19 	
	base-outfit@outwit.com 	1.0.3.11 	
	outwit-images@outwit.com 	0.3.3.19 	
	{5fb1186a-3398-4c47-b579-0f2eee222ad1} 	1.0.3.11 	
	davidcarver88@gmail.com 	0.3.7 	
	{24cea704-946d-11da-a72b-0800200c9a66} 	1.1.3 	
	service@touchpdf.com 	1.15 	
	{C0CB8BA3-6C1B-47e8-A6AB-1FAB889562D9} 	0.6.0.7 	
	rotateimage@minisystems.de 	0.1.3.2 	
	savefileto@mozdev.org 	2.0.2 	
Screengrab 	{02450954-cdd9-410f-b1da-db804e18c671} 	0.96.3 	current
	kosa@kallout.com 	2.0.1.1 	
	{64161300-e22b-11db-8314-0800200c9a66} 	0.9.5.8 	
	statusable.wayne@ptaff.ca 	0.9.7 	
	{3541c267-2580-4144-854e-2e05c8670121} 	1.5.9 	
	{4776510a-a1f4-41f3-a3c8-35b474ecef23} 	1.0.8 	
	tabscope@xuldev.org 	1.1 	
	{792BDDFE-2E7C-42ed-B18D-18154D2761BD} 	0.9.6 	
	{03B08592-E5B4-45ff-A0BE-C1D975458688} 	1.0 	
	TooManyTabs@visibotech.com 	1.3.2 	
	TFToolbarX@torrent-finder 	1.2.6 	
	unplug@compunach 	2.044 	
User Agent Switcher 	{e968fc70-8f95-4ab9-9e79-304de2a71ee1} 	0.7.3 	current
	{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7} 	20100908 	
	{89f8dde0-010a-11da-8cd6-0800200c9a66} 	1.0.0.21 	
	yesscript@userstyles.org 	1.9 	
	multilinks@plugin 	3.0.0.16 	
	{76C80A11-FAD4-406c-8246-F5ED4F9367B5} 	0.1.7 	
Linky 	linky@gemal.dk 	3.0.0 	current
	{210249CE-F888-11DD-B868-4CB456D89593} 	3.0.2 	
	{04b56b3f-c4f4-48ba-9ea1-30e04fb7d829} 	2.6.20091103 	
Mozilla Archive Format, with MHT and Faithful Save 	{7f57cf46-4467-4c2d-adfa-0cba7c507e54} 	1.0.0 	current
	amin.eft_Shutdown@gmail.com 	3.6.2D 	
	{81BF1D23-5F17-408D-AC6B-BD6DF7CAF670} 	7.1.1.2 	
	foxvox@wordit.com 	1.7.7 	
	simpletimerClocks@grbradt.org 	1.3.2 	
	{A6A0B3F6-6D2D-4c55-96C1-7481BEA2EBF8} 	2.1.73 	
	{ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a} 	1.4.1 	
	{4176DFF4-4698-11DE-BEEB-45DA55D89593} 	0.8.7 	
	{A4732521-77D9-447E-A557-B279AC923F06} 	0.6.8 	
	LDSI_plashcor@gmail.com 	0.6.8 	
NoScript 	{73a6fe31-595d-460b-a920-fcc0f8843232} 	2.0.9.9 	current
	PrivacyPlus@PeterOlayev.com 	1.0.1 	
	maxacookie@maxatools.com 	3.5.1 	
	{FA4658DE-935B-4f39-AED3-0B5034DDE225} 	2.1.2009091201 	
	bossknb@ttt-jl.blogspot.com 	2.1 	
	{0b38152b-1b20-484d-a11f-5e04a9b0661f} 	5.6.12.1 	
	{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB} 	2.12.21.1 	
	{1b8cc170-8c85-11db-b606-0800200c9a66} 	3.4.2 	
	gmailnoads@mywebber.com 	3.3.2 	
Tab Mix Plus 	{dc572301-7619-498c-a57d-39143191b318} 	0.3.8.5 	current
	{078fac48-925f-4524-7cfe-85d44b8f4f98} 	1.2 	
	{3112ca9c-de6d-4884-a869-9855de68056c} 	7.1.20101113Wb1 	
	wisestamp@wisestamp.com 	2.0.10 	
	anttoolbar@ant.com 	2.3.0 	
	{2f17f610-5e97-4fed-828f-9940b7b577a4} 	1.6.5 	
	{bee6eb20-01e0-ebd1-da83-080329fb9a3a} 	0.1 	
	cookieSwap@cookieSwap.mozdev.org 	0.5.253 	
	firefox@red-cog.com 	2.8 	
	{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA} 	6.0.21 	
	{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA} 	6.0.22 	
	{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA} 	6.0.23 	
	optimizegoogle@optimizegoogle.com 	0.78.2 	
	toolbar@ask.com 	3.9.1.14019 	
	{972ce4c6-7e08-4474-a285-3208198ce6fd} 	3.6.15
Could you try disabling Rewind/Fastforward Buttons?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Could you try disabling Rewind/Fastforward Buttons?

Thanks that seemed to do the trick.  Thanks for saving me a bunch of time in not having to disable half of my add-ons and trying to figure it out through elimination process.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Looks like blocklisting might be good.
Status: RESOLVED → REOPENED
Component: General → Blocklisting
Ever confirmed: true
Product: Firefox → addons.mozilla.org
QA Contact: general → blocklisting
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Looks like blocklisting might be good.

What is blocklisting?
(Reporter)

Comment 5

8 years ago
I looked up and you are right blocklisting might be good in this case.
Blocklisting needs the UUID and Version.
This bug is a JS Engine bug:
0 	js3250.dll 	js_ExecuteRegExp 	js/src/jsregexp.cpp:4883
1 	js3250.dll 	regexp_exec_sub 	js/src/jsregexp.cpp:5696
2 	js3250.dll 	regexp_test 	js/src/jsregexp.cpp:5721
3 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
4 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
5 	js3250.dll 	array_extra 	js/src/jsarray.cpp:3207
6 	js3250.dll 	array_forEach 	js/src/jsarray.cpp:3263
7 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
8 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
9 	js3250.dll 	array_extra 	js/src/jsarray.cpp:3207
10 	js3250.dll 	array_forEach 	js/src/jsarray.cpp:3263
11 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208

You can't block the extension without telling the author how he can avoid the JS Engine bug. You have probably access to bug 559234 but I think this should go to JS Engine first.
Assignee: nobody → general
Component: Blocklisting → JavaScript Engine
Product: addons.mozilla.org → Core
QA Contact: blocklisting → general
Summary: Firefox crashes every time launched or opened. → Firefox crashes every time launched or opened. [@ js_ExecuteRegExp]
Version: unspecified → 1.9.2 Branch

Comment 7

5 years ago
unpitt, do you still crash?
Flags: needinfo?(unpitt23)
(Reporter)

Comment 8

5 years ago
hi, Wayne no the crashing was resolved.  That is why I haven't even been on this thread any longer.
Flags: needinfo?(unpitt23)

Comment 9

5 years ago
all crashes are version 3.x and 4.x
Status: REOPENED → RESOLVED
Crash Signature: [@ js_ExecuteRegExp ]
Last Resolved: 8 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.