Status

()

Core
Widget: Gtk
--
major
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Bernd Paysan, Unassigned)

Tracking

({inputmethod})

Trunk
x86_64
Linux
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12) Gecko/20110222 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12) Gecko/20110222 Firefox/4.0b12

All attempts to use scim to enter e.g. Chinese characters fail. Other GTK applications like gimp and Qt applications work fine together with scim.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Put cursor into any editable field
3. Press Ctrl+Space to activate scim -> nothing happens
Actual Results:  
Nothing happens

Expected Results:  
Scim input bar should show up and allow using the input method editor to enter e.g. Chinese characters.

This is the Firefox build distributed with OpenSuSE 11.4.
(Reporter)

Updated

7 years ago
Keywords: inputmethod
Version: unspecified → Trunk
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor

Comment 1

7 years ago
Masayuki, is this a known IME problem?
No. But if this report is true, this must be a bug of widget.

Bernd: How about our build? OpenSuSE's build might change something.
Component: Editor → Widget: Gtk
QA Contact: editor → gtk
I think that SCIM uses keysnooper. So, I guess that the Chinese input engine for SCIM failed something *before* we handle the native key event...
Same here, using the FF build of Archlinux (http://projects.archlinux.org/svntogit/packages.git/tree/firefox/repos/extra-x86_64/ and http://projects.archlinux.org/svntogit/packages.git/tree/xulrunner/repos/extra-x86_64/).

Console output when starting (once more each time a window is opened or closed):

(firefox:15575): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox:15575): Gtk-WARNING **: Loading IM context type 'scim' failed
OpenOffice path before fixup is '/usr/lib/openoffice.org3'
OpenOffice path is '/usr/lib/openoffice.org3'

(firefox:15575): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox:15575): Gtk-WARNING **: Loading IM context type 'scim' failed

(firefox:15575): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox:15575): Gtk-WARNING **: Loading IM context type 'scim' failed
(Reporter)

Comment 5

7 years ago
Tried it with the official firefox 4.0 build, same result:

(firefox-bin:12056): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox-bin:12056): Gtk-WARNING **: Loading IM context type 'scim' failed

(repeats as Philipp reports).
I wonder whether the module could be getting unused and reused, and not re-registering the type on reuse.
I can reproduce this bug on OpenSuSE 11.4 with its default build. However, I cannot reproduce this bug with a debug build which I built on OpenSuSE 11.4...
I can see:

> (firefox:20058): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim-bridge.so' failed to register type 'ScimBridgeClientIMContext'
> 
> 
> (firefox:20058): Gtk-WARNING **: Loading IM context type 'scim-bridge' failed
> *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
> 
> (firefox:20058): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim-bridge.so' failed to register type 'ScimBridgeClientIMContext'
> 
> 
> (firefox:20058): Gtk-WARNING **: Loading IM context type 'scim-bridge' failed
> 
> (firefox:20058): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim-bridge.so' failed to register type 'ScimBridgeClientIMContext'
> 
> 
> (firefox:20058): Gtk-WARNING **: Loading IM context type 'scim-bridge' failed
>
(Reporter)

Comment 11

7 years ago
(In reply to comment #9)
> Hmm, I cannot reproduce this bug with our official build too.

I tried both the 32 and 64 bit official build, and I can reproduce it with both. I'm now trying to create my own debug build, and see what happens there.
(Reporter)

Comment 12

7 years ago
Ok, "Minefield 4.0" build on OpenSuSE 11.4 fails the same way:

(firefox-bin:11387): GLib-GObject-WARNING **: plugin '/usr/lib64/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox-bin:11387): Gtk-WARNING **: Loading IM context type 'scim' failed

As already said, other GTK apps (Gnome, GIMP) work fine with Scim.
Hm, I'd like you to report this bug to SCIM community. The GtkIMContextSCIM registration is done by SCIM but it failed. We're creating IM context with gtk_im_multicontext_new(). So, we don't do any special things...

When I searched the error messages, I saw some similar problems on old Ubuntu which was used SCIM. Couldn't they help you?
One thing that looks different between scim and xim modules is that, in scim, im_module_init only registers the type the first time it is called.  (xim registers each time the init function is called.)

I'm not clear on correct GTypeModule usage.  There seemed to be some confusion in the documentation itself to me, but this is a significant difference that would lead to this problem if the module gets unused and re-used.

That would be a SCIM bug, but it may be worth trying to hold a reference to the class as another workaround here:
http://hg.mozilla.org/mozilla-central/annotate/b853c6efa929/widget/src/gtk2/nsGtkIMModule.cpp#l324
(I haven't thoroughly checked how ownership works but I'm hoping a class reference will prevent the module getting unused.)
(Reporter)

Comment 16

7 years ago
Ok, checked this test build, but unfortunately, the problem still persists.

Tested also on OpenSuSE 11.3, there both the official Firefox release and the test build allow to activate scim.
This bug was fixed by OpenSuSE side, isn't it?
https://bugzilla.novell.com/show_bug.cgi?id=680430

marking as WONTFIX, if I'm misunderstanding about the status, feel free to reopen this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 18

7 years ago
Yes, was a scim-bridge-gtk problem in OpenSuSE, fixed.
I'm having the same issue with Gentoo. I've made an world update and installed www-client/firefox-10.0.5 and mail-client/thunderbird-10.0.5. I know that these two versions are not the latest stable ones so I downloaded the binary versions from the respective websites and checked with them and the problem could be reproduced.

Every time I start firefox or thunerbird I get the error

(firefox:5259): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox:5259): Gtk-WARNING **: Loading IM context type 'scim' failed


I use scim and not scim-bridge (for some strange reason scim-bridge doesn't work at all with any program) but I gues the problem is the same. I can use scim with QT and other GTK+ programs like gedit oder gimp, so at least I know that GTK+ programs can work with my current scim installation.

I searched the Gentoo's bugtracker and found https://bugs.gentoo.org/show_bug.cgi?id=390053
could this one be related to my actual problem?
Looks like the same issue.
Upstream report (that this bugzilla won't accept in See Also) is
http://sourceforge.net/tracker/?func=detail&aid=3439449&group_id=108454&atid=650539
You need to log in before you can comment on or make changes to this bug.