Twitter unable to find 1 day old tweet

VERIFIED WONTFIX

Status

www.mozilla.org
General
VERIFIED WONTFIX
7 years ago
6 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Searching the mosaic, I looked up this tweet:
http://twitter.com/#!/rerlin6A/status/49279015881674750

I clicked the tweet I made yesterday. It is the last tweet I made, and displays at the top of my twitter account: http://twitter.com/#!/rerlin6A

It shouldn't lose tweets in 24 hours

Comment 1

7 years ago
Sorry, but the tweet you linked is not available at twitter.com:
http://twitter.com/#!/rerlin6A/status/49279015881674750

Searching for "rerlin6A" at http://twittercollage.allizom.org/ shows the same tweet I now see at the top of http://twitter.com/#!/rerlin6A

Searching for "rerlin6A" at http://twittercollage.allizom.org/dashboard/dashboard.php shows 2 tweets

Please note that your staging is now searching for "firefox" and not the official hashtag

Also, I don't know WHEN exactly the stage was last updated and booted but I can see that it missed a tweet from 19 Mar. 

The 17th Mar tweet is there (because the database was certainly not erased meanwhile) and it's also kind of older than 24h.

I guarantee you that the system does not loose any tweets. Twitter API itself may filter some tweets, as we previously checked, but once they're in the party system they will only disapear if deleted in the dashboard.

As long as the system is running, of course, and it seems to be running fine since last updated.
OS: Mac OS X → Windows 7
Pretty sure this is because the Mozilla stage server is only searching for "firefox" tweets and not the hashtags that it will search for on production. Since it works on the Quodis stage server (which has the proper search terms set up), I'm marking this as wontfix.

It should work as expected on production, and as Andre mentioned, the database only deletes tweets when they're removed using the dashboard.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

7 years ago
My concern was about twitter not finding the tweet after such a short time. Initially we thought the cause was because it was overwritten by new data- but I see that isn't the case. I'll test more with the #firefox hashtag.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.