At times, some entries in the built-in download manager would get stuck at scanning for viruses.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: linotechie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

Sometimes, but not always, when a download is complete, the browser's built-in download manager would keep displaying it with a progress bar with moving strips; the text displayed is "Scanning for viruses...". Pressing Delete after selecting it doesn't remove it, nor its right-click menu has an option to remove this entry.

Now, the real problem arises when you close the browser without getting rid of this download entry: when the browser is started the next time, it thinks that the stuck entry was not downloaded successfully and redownloads the file, thereby deleting the already downloaded file! Very frustrating, particularly when the file is a large one or you have to pay for downloading a copy of some file. Some downloads are not resumable (they generate a new URL each time); in those cases the downloaded file is deleted and an HTML file with an error message replaces it.

A workaround could be to rename the file whose entry is unfortunately stuck in the download manager.

A possibly great addition would be to provide an option to not scan for the viruses on completion of the download, as most antivirus apps do that automatically anyway. A browser's job is to download the requested file; it should not try to be over-smart if the user doesn't want it to.

Reproducible: Sometimes

Steps to Reproduce:
1. Download a file using the default (in-built) download manager.
2. After the download is complete, see if the download manager is stuck at scanning it for viruses. Sometimes it will.
3. If the entry gets stuck scanning for viruses, close the browser and start it again (right now or at any time).
Actual Results:  
Your download is gone. The browser attempts to download the file again.

Expected Results:  
The entry in the download manager should have indicated that the download is complete as soon as it is. And there should be an option to remove that entry ANY TIME even if the download is currently going on. To prevent accidental removal, that option should be provided in the context menu for the entry and not via the Delete button.
(Reporter)

Comment 1

8 years ago
Found a setting not available via the options UI but hidden inside the about:config page. To disable the virus scanning upon completion of a download, open the about:config page, look up the following boolean preferences:

browser.download.manager.scanWhenDone
services.sync.prefs.sync.browser.download.manager.scanWhenDone

and set both of them to false. I'm yet to encounter the above mentioned problem after doing this (also, I'm currently using version 4). Hopefully the problem is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
See Also: → bug 644972
(Reporter)

Comment 2

8 years ago
As I applied the above fix, a new bug seems to have surfaced. Here it is: https://bugzilla.mozilla.org/show_bug.cgi?id=644972
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.