Paypal lightbox takes a while to load

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Q3 2011

Details

(Whiteboard: [paypal], URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Posted image screenshot
steps to reproduce:
1. Click on contribute button @ https://addons.allizom.org/en-US/firefox/addon/reminderfox/
2. Make a one-time contribution of $1

observed behavior:
After clicking 'make contribution', there is a considerable lag before the papyapl lightbox loads.

Check screenshot for loading times
I've been blaming this on sandbox.p.c being crappy and hoping it wouldn't be this way with the live site.  Andy, is that a reasonable assumption?

Comment 2

8 years ago
Yeah I can only hope it will be faster in production. 

When you click contribute we ping the a.m.o server with an ajax request, which pings paypal and returns back the paykey, then the paypal script kicks in and creates the overlay and the pay lightbox.

There's a period between clicking that and creating the overlay that we can do something in, but I wasn't quite sure what to do there that didn't look sucky since paypal kicks in and creates an overlay and lightbox...
Sounds like there is going to be a period of lag there no matter what we do.  We could do a small spinner-on-element (CCing chowse).

I'm willing to see what it looks like in production to see if it's just the sandbox.  If it happens in production too, we should ask paypal about better options.  Putting in Q22011, but if it's bad in prod we should address it early.
Priority: -- → P3
Target Milestone: 6.0.2 → Q2 2011
(In reply to comment #3)
> Sounds like there is going to be a period of lag there no matter what we do. 
> We could do a small spinner-on-element (CCing chowse).

Do we know when the AJAX request is completed and the Paypal lightbox is about to appear? The spinner UI could be added to the first pop-up, provided we only dismiss it once the second lightbox is ready.

Comment 5

8 years ago
Yes. 

With the clarification that we know then the Paypal grey overlay appears. That's where we hand off to paypal, the Paypal lightbox will appear some period after that. Sometimes I've seen the paypal overlay to lightbox be quite delayed as well.

There's two different entry points to the paypal process: the contribute modal on the details page and the contribute link on the featured listing page
I talked to paypal on the phone today.  Their stage site, much like ours, is a lot slower than production.  The plan is to push paypal on the 31st of this month.  Let's reevaluate whether we need to do something in this bug then.
Whiteboard: [paypal]
Five redirects before hitting the first 200 make for a slow experience. This is all from the initial load.

Comment 8

8 years ago
It looks like we can eliminate a couple of those by altering our urls in settings.
It looks like the URL we're using:

> https://paypal.com/webapps/adaptivepayment/flow/pay?paykey=value&preapprovalkey=value

Is what paypal's documentation has listed on page 230 of the Adaptive Payments Developer Guide, so we shouldn't change that without talking to them.  I'll ask in our next meeting.
Target Milestone: Q2 2011 → Q3 2011
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.