Make mac buttons (and menulists) scalable (9 pieces)

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Themes
P1
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: andreww, Assigned: andreww)

Tracking

({classic})

Trunk
mozilla0.9
PowerPC
Mac System 8.5
classic

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

18 years ago
Hyatt needs mac classic buttons to be scalable for XBL-ification of HTML
widgets. This is a tracker bug for that fix.
(Assignee)

Comment 1

18 years ago
Accepting.
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 2

18 years ago
--> Themes.

Are there equivalent bugs for popup menus, radio buttons, and checkboxes?
Component: User Interface: Design Feedback → Themes
QA Contact: mpt → pmac
(Assignee)

Comment 3

18 years ago
scalable radio buttons? Ask hyatt, he asked me to open this bug.
(Assignee)

Comment 4

18 years ago
Adding depends on getting graphics...
Depends on: 65676

Comment 5

18 years ago
Themes Triage Team nsbeta1+
(Assignee)

Comment 6

18 years ago
setting milestone
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 7

18 years ago
I'm making great progress on this but it's looking more like it'll be in the .9
release. It's still my top priority however.
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Comment 8

18 years ago
changing summary to include menulists, as they need 9 piece scaling too...
Summary: [classic] Mac - make mac classic buttons scalable (9 pieces) → [classic] Mac - make mac classic buttons (and menulists) scalable (9 pieces)
(Assignee)

Comment 9

18 years ago
*** Bug 67385 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
No longer depends on: 65676
(Assignee)

Comment 10

18 years ago
*** Bug 65676 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
This is just about ready - I have local versions working and I'm incorporating
them into my tree today.
(Assignee)

Comment 12

18 years ago
this bug is ready for review... I'll be adding the following files to the
repository:

mozilla/themes/classic/global/mac/button-active-left-btm.gif
mozilla/themes/classic/global/mac/button-active-left-mid.gif
mozilla/themes/classic/global/mac/button-active-left-top.gif
mozilla/themes/classic/global/mac/button-active-mid-btm.gif
mozilla/themes/classic/global/mac/button-active-mid-mid.gif
mozilla/themes/classic/global/mac/button-active-mid-top.gif
mozilla/themes/classic/global/mac/button-active-right-btm.gif
mozilla/themes/classic/global/mac/button-active-right-mid.gif
mozilla/themes/classic/global/mac/button-active-right-top.gif
mozilla/themes/classic/global/mac/button-def-active-left-btm.gif
mozilla/themes/classic/global/mac/button-def-active-left-mid.gif
mozilla/themes/classic/global/mac/button-def-active-left-top.gif
mozilla/themes/classic/global/mac/button-def-active-mid-btm.gif
mozilla/themes/classic/global/mac/button-def-active-mid-mid.gif
mozilla/themes/classic/global/mac/button-def-active-mid-top.gif
mozilla/themes/classic/global/mac/button-def-active-right-btm.gif
mozilla/themes/classic/global/mac/button-def-active-right-mid.gif
mozilla/themes/classic/global/mac/button-def-active-right-top.gif
mozilla/themes/classic/global/mac/button-def-dis-left-btm.gif
mozilla/themes/classic/global/mac/button-def-dis-left-mid.gif
mozilla/themes/classic/global/mac/button-def-dis-left-top.gif
mozilla/themes/classic/global/mac/button-def-dis-mid-btm.gif
mozilla/themes/classic/global/mac/button-def-dis-mid-top.gif
mozilla/themes/classic/global/mac/button-def-dis-middle.gif
mozilla/themes/classic/global/mac/button-def-dis-right-btm.gif
mozilla/themes/classic/global/mac/button-def-dis-right-mid.gif
mozilla/themes/classic/global/mac/button-def-dis-right-top.gif
mozilla/themes/classic/global/mac/button-def-left-btm.gif
mozilla/themes/classic/global/mac/button-def-left-mid.gif
mozilla/themes/classic/global/mac/button-def-left-top.gif
mozilla/themes/classic/global/mac/button-def-mid-btm.gif
mozilla/themes/classic/global/mac/button-def-mid-mid.gif
mozilla/themes/classic/global/mac/button-def-mid-top.gif
mozilla/themes/classic/global/mac/button-def-right-btm.gif
mozilla/themes/classic/global/mac/button-def-right-mid.gif
mozilla/themes/classic/global/mac/button-def-right-top.gif
mozilla/themes/classic/global/mac/button-dis-left-btm.gif
mozilla/themes/classic/global/mac/button-dis-left-mid.gif
mozilla/themes/classic/global/mac/button-dis-left-top.gif
mozilla/themes/classic/global/mac/button-dis-mid-btm.gif
mozilla/themes/classic/global/mac/button-dis-mid-mid.gif
mozilla/themes/classic/global/mac/button-dis-mid-top.gif
mozilla/themes/classic/global/mac/button-dis-right-btm.gif
mozilla/themes/classic/global/mac/button-dis-right-mid.gif
mozilla/themes/classic/global/mac/button-dis-right-top.gif
mozilla/themes/classic/global/mac/button-left-btm.gif
mozilla/themes/classic/global/mac/button-left-mid.gif
mozilla/themes/classic/global/mac/button-left-top.gif
mozilla/themes/classic/global/mac/button-mid-btm.gif
mozilla/themes/classic/global/mac/button-mid-mid.gif
mozilla/themes/classic/global/mac/button-mid-top.gif
mozilla/themes/classic/global/mac/button-right-btm.gif
mozilla/themes/classic/global/mac/button-right-mid.gif
mozilla/themes/classic/global/mac/button-right-top.gif
mozilla/themes/classic/global/mac/menulist-act-right-scalebit.gif
mozilla/themes/classic/global/mac/menulist-active-arrow.gif
mozilla/themes/classic/global/mac/menulist-active-left-btm.gif
mozilla/themes/classic/global/mac/menulist-active-left-mid.gif
mozilla/themes/classic/global/mac/menulist-active-left-top.gif
mozilla/themes/classic/global/mac/menulist-active-mid-btm.gif
mozilla/themes/classic/global/mac/menulist-active-mid-mid.gif
mozilla/themes/classic/global/mac/menulist-active-mid-top.gif
mozilla/themes/classic/global/mac/menulist-active-right-btm.gif
mozilla/themes/classic/global/mac/menulist-active-right-mid.gif
mozilla/themes/classic/global/mac/menulist-active-right-top.gif
mozilla/themes/classic/global/mac/menulist-arrow.gif
mozilla/themes/classic/global/mac/menulist-compact-arrow.gif
mozilla/themes/classic/global/mac/menulist-dis-arrow.gif
mozilla/themes/classic/global/mac/menulist-dis-left-btm.gif
mozilla/themes/classic/global/mac/menulist-dis-left-mid.gif
mozilla/themes/classic/global/mac/menulist-dis-left-top.gif
mozilla/themes/classic/global/mac/menulist-dis-mid-btm.gif
mozilla/themes/classic/global/mac/menulist-dis-mid-mid.gif
mozilla/themes/classic/global/mac/menulist-dis-mid-top.gif
mozilla/themes/classic/global/mac/menulist-dis-right-btm.gif
mozilla/themes/classic/global/mac/menulist-dis-right-mid.gif
mozilla/themes/classic/global/mac/menulist-dis-right-scalebit.gif
mozilla/themes/classic/global/mac/menulist-dis-right-top.gif
mozilla/themes/classic/global/mac/menulist-left-btm.gif
mozilla/themes/classic/global/mac/menulist-left-mid.gif
mozilla/themes/classic/global/mac/menulist-left-top.gif
mozilla/themes/classic/global/mac/menulist-mid-btm.gif
mozilla/themes/classic/global/mac/menulist-mid-mid.gif
mozilla/themes/classic/global/mac/menulist-mid-top.gif
mozilla/themes/classic/global/mac/menulist-right-btm.gif
mozilla/themes/classic/global/mac/menulist-right-mid.gif
mozilla/themes/classic/global/mac/menulist-right-scalebit.gif
mozilla/themes/classic/global/mac/menulist-right-top.gif

----

Now adding attachments for the diffs
(Assignee)

Comment 13

18 years ago
Created attachment 24841 [details] [diff] [review]
all diffs for this bug - various files
(Assignee)

Updated

18 years ago
Keywords: review

Comment 14

18 years ago
>     background                        : 
url("chrome://global/skin/button-left-top.gif") no-repeat;
>     height          : 4px;
is there a reason the two :'s don't align?

Comment 16

18 years ago
sr=hewitt
(Assignee)

Comment 17

18 years ago
checked in yesterday - fixed both buttons and menulists.
QA - if you need a test page for this, let me know .
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
Small buttons (those which use Geneva 10 or similar for their text) now appear to 
be one or two pixels too short. Was that caused by this bug?
(Assignee)

Comment 19

18 years ago
Created attachment 25637 [details]
this is a test xul file for buttons - shows that they can scale
(Assignee)

Comment 20

18 years ago
Created attachment 25638 [details]
zip containing two tests - one for buttons and one for menulists.
(Assignee)

Comment 21

18 years ago
pmac: I added an attachment "zip containing...." which is a zip file containing
xul files which you can open in the browser and test the scaling of menulists
and buttons.  Unzip the whole thing to some directory and open test.xul, and
then menulist.xul 

You can see the differences by going to a prev-build and see how it's different.

Comment 22

18 years ago
Thanks very much, Andrew. I will verify it.

Comment 23

18 years ago
Marking verified on Mac (2001-02-31-04-Mtrunk).
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: classic

Updated

18 years ago
Keywords: review
Summary: [classic] Mac - make mac classic buttons (and menulists) scalable (9 pieces) → Make mac buttons (and menulists) scalable (9 pieces)
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.