The browser crashes after switching themes and clicking on the "Reload" button for several times

VERIFIED DUPLICATE of bug 64352

Status

VERIFIED DUPLICATE of bug 64352
18 years ago
11 years ago

People

(Reporter: pmac, Assigned: bugs)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Platform: Windows 98 (2001-01-02-21-Mtrunk)

Steps to reproduce:

1. Launch Netscape 6.
2. Select View>Apply Theme> Classic.
3. Select Edit>Preferences>Navigator and click on the 'bookmark'.
4. The "Bookmarks" folder is located on the personal tool bars.
5. Pull own the Bookmarks folder/Imported IE Favorites/Media/MSNBC
   or /What's on Now/ or /Blomberg/and continue do this for several
   time and click on the "Reload" button.
6. Switch back to Modern and follow step #5
7. Switch back to Classic and follow step #5

NOTE: The browser crashes. I can always reproduce every time.

Below here is the talkback report:

Trigger Type:   Program Crash
<../images/spacer.gif>
Trigger Reason:  Access violation
<../images/spacer.gif>
Thread ID:
<../images/spacer.gif>
Call Stack:    (Signature = nsCOMPtr_base::~nsCOMPtr_base 9fada455)
     nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
     nsCodebasePrincipal::~nsCodebasePrincipal
[d:\builds\seamonkey\mozilla\caps\src\nsCodebasePrincipal.cpp]
     nsCodebasePrincipal::`scalar deleting destructor'
     nsSystemPrincipal::Release
[d:\builds\seamonkey\mozilla\caps\src\nsSystemPrincipal.cpp, line 46]
     nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
     GlobalWindowImpl::~GlobalWindowImpl
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 162]
     FinalizeElement
[d:\builds\seamonkey\mozilla\dom\src\coreDOM\nsJSElement.cpp, line 153]
     js_FinalizeObject [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1630]
     FinalizeElement
[d:\builds\seamonkey\mozilla\dom\src\coreDOM\nsJSElement.cpp, line 153]
     js_FinalizeObject [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1630]
     js_GC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 1200]
     js_ForceGC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 932]
     JS_GC [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1596]
     nsJSContext::GC
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1309]
     0x0e8f9010
     DocumentViewerImpl::Init
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 539]
     nsDocShell::SetupNewViewer
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2961]
     nsWebShell::SetupNewViewer
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 361]
     nsDocShell::Embed
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2514]
     nsWebShell::Embed
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 385]
     nsDocShell::CreateContentViewer
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2740]
     nsDSURIContentListener::DoContent
[d:\builds\seamonkey\mozilla\docshell\base\nsDSURIContentListener.cpp, line 104]
     nsDocumentOpenInfo::DispatchContent
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 370]
     nsDocumentOpenInfo::OnStartRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 242]
     nsHTTPFinalListener::OnStartRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 1127]
     InterceptStreamListener::OnStartRequest
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCachedNetData.cpp, line 1191]
     nsHTTPServerListener::FinishedResponseHeaders
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 1065]
     nsHTTPServerListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 428]
     nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 413]
     nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 101]
     PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 577]
     PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 513]
     _md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 1055]
     KERNEL32.DLL + 0x24407 (0xbff94407)
     0x00688b5a
<../images/spacer.gif>

Comment 1

18 years ago
Sent twice

*** This bug has been marked as a duplicate of 64352 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verifying.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.