dynamic form elements style not applied

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: alex.dent, Assigned: Pierre Saslawsky)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
form elements (input and textarea tested) that are inserted with innerHTML or as
a contextualFragment ignore their style, even though the same style on a static
element works.

the workaround is to use a class instead of a style, but this is ugly because i
would need 100s of classes for my various form elements...

see the testcase.
(Reporter)

Comment 1

17 years ago
Created attachment 21811 [details]
test case
(Reporter)

Comment 2

17 years ago
btw, i use build 2001010408 on mac.

Comment 3

17 years ago
Sigh, another problem about innerHTML. Please note that innerHTML is not a w3c
standard and was (poorly) implemented in mozilla for compatibility issues. If at
all possible it should be avoided.
(Reporter)

Comment 4

17 years ago
this problem is not innerHTML specific, i just used innerHTML in the test case. i
originally noticed that problem using ranges & createContextualFragment, which
imho are a well defined dom2 w3c standard (though i don´t know how it´s
implemented, there are a lot of functions left out in mozillas current Range
class). 

Comment 5

17 years ago
Looks to be a bug to me (Mac 2001010908). Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
(Assignee)

Comment 7

17 years ago
Works for me in recent builds.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.