"Search By Change History" date fields behave wrongly when searching by "Hours Worked" field

RESOLVED DUPLICATE of bug 58179

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 58179
7 years ago
7 years ago

People

(Reporter: erkiha@gmail.com, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 4.1.1+

When limiting "Hours Worked" search by date fields, bugzilla does not include bugs changed on last date of limiting range.

This is because Hours worked field in database saves also time value but date field search screen does not allow time value to be entered. Because of this bugzilla assumes date-to field having time 00:00:00 but hours worked time value in database is different.

This is not expected. Correct behaviour should be to assume dateto field having time "23:59:59"

Reproducible: Always

Steps to Reproduce:
1.Add some hours to Hours worked field.
2.In search screen go to Advanced search and Search by Change History
3.Select Hours Worked from first selection box
4.Fill both date fields with todays date.

Actual Results:  
Bug is not selected

Expected Results:  
Bug should be selected because I changed Hours worked field of bug today.

Bug will get selected when leaving dateto field empty or fill it with Now or fill it with today+1 date.

Updated

7 years ago
Keywords: qawanted
Whiteboard: DUPME

Updated

7 years ago
Assignee: charting → query-and-buglist
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: Reporting/Charting → Query/Bug List
Keywords: qawanted
Resolution: --- → DUPLICATE
Whiteboard: DUPME
Version: unspecified → 4.1.1
Duplicate of bug: 58179
You need to log in before you can comment on or make changes to this bug.