Closed Bug 643770 Opened 9 years ago Closed 3 years ago

Auto scroll does not stop when mouse wheel is turned

Categories

(Toolkit :: XUL Widgets, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: alice0775, Assigned: enndeakin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre ID:20110322030409

Auto scroll does not stop when mouse wheel is turned

This behavior is different from Firefox3.6.*.
In Firefox3.6.*,auto scroll stops when mouse wheel is turned.

This is opposite of Bug 518246.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile.
2. Enable autoscroll
3. Open any page (long enough)
4. Start Autoscroll by clicking middle button and move
5. Turn mouse wheel

Actual Results:  
Auto scroll does not stop

Expected Results:  
Auto scroll should stop

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/136b3db3e75d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre ID:20110119185324
Broken:
http://hg.mozilla.org/mozilla-central/rev/9b6a73bdb237
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre ID:20110119205425
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=136b3db3e75d&tochange=9b6a73bdb237
Suspected:
9c96acb338ca	Felipe Gomes — Bug 597723. Mouse scrolling shouldn't dismiss panel notifications. r=enndeakin a=blocking-final
See Also: → 518246
Should be default behaviour, very weird after Opera usage.
Blocks: 1303903
rolluponmousewheel is used for wheel events outside the popup; since that doesn't apply to events when the mouse is over the autoscroll arrow popup, the listener is used for this.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8801843 - Flags: review?(felipc)
Attachment #8801843 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/d3c97dbe7e36
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Depends on: 1327614
Great that was fixed, but this patch broke the ability to scroll pixel by pixel by rotating mousewheel over the autoscroll icon.

I was able to revert to the desired behavior by copying the mousemove handler conditional to the DOMMouseScroll handler:

              case "DOMMouseScroll": {
+                var x = aEvent.screenX - this._startX;
+                var y = aEvent.screenY - this._startY;
+
+                if ((x > this._AUTOSCROLL_SNAP || x < -this._AUTOSCROLL_SNAP) ||
+                    (y > this._AUTOSCROLL_SNAP || y < -this._AUTOSCROLL_SNAP)) {
                  this._autoScrollPopup.hidePopup();
                  event.preventDefault();
+                }

This way you can both stop autoscroll turning wheel and scroll pixel by pixel by turning wheel over autoscroll icon.
Depends on: 1345989
You need to log in before you can comment on or make changes to this bug.