Positioning erro with position:fixed + floating errors

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: tapio.markula, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Look at the example page. 
It has also a
screen capture image, how the page SHOULD be rendered (Opera 5.01):
http://www.nic.fi/~tapio1/Tests/Girl.html

Other remarks:

I would like to recommend to install Mozilla in my CSS-introduction site and visit in my CSS-site with Mozilla, but I can't give this recommendation because of some bugs.

The biggest is that MOZILLA DOESN'T RENDER ALL CONTENT OF MY SITE!

I can't understand, why Mozilla 0.6 can't render CITE as the child of BLOCKQUOTE - It render just a yellow line.

For example: http://www.nic.fi/~tapio1/Teaching/Elementitc.html
has a long cite, which Mozilla 0.6 doesn't render
- Works fine in Opera 5.01 and MS IE 5.5 Win. Used CSS:
http://www.nic.fi/~tapio1/Css/seurakunta-netscape.css
http://www.nic.fi/~tapio1/Css/seurakunta.css
http://www.nic.fi/~tapio1/Css/seurakunta-ohitus.css

In other matters I could give the estimation to Mozilla 0.6 as good of as Opera 5.01. Today Opera 5.x renders my CSS-site best.

Both have tiny flaws, but really tiny and following are just temporary bugs in Mozilla 0.6:
- html {background-color...} /* doesn't work, but I know that this is fixed*/
- a[target="new"] {background-color...}  /* worked in some earlier build */

The only matter, which in this site, which works only in Mozilla is :focus. In other respect Opera renders as well or better. The site looks always best with Opera 5.x because Opera and Mozilla interprets 'viewport' differently. Because I don't like to recommend MS IE, I put only advertisement of Opera 5.0.

I can't recommend to visit with Mozilla to my other sites! Sorry.
The biggest reason is that my site doesn't look good with Mozilla:

1) If a list have several links, the text drifts, because :hover cause that Mozilla put text, which should not be bold as bold, for example:
http://www.nic.fi/~tapio1/Yleiset/Tecnicsu.html
<tr valign="top">
<td valign="top" colspan="6">
<ul class="tyo">
<li><a href="../Tools/WP8jatkob.htm"><b>
Ohjelmistoarviointejani</b></a> <b><a href= 
"javascript:uusikkunab();" onmouseout="window.status='';return 
true" onmouseover="window.status='Pop-up\ -ikkuna;\ osoite:\ \
http://www.corel.com/products/wordperfect/cwps8/index.htm';return 
true">Corel Word Perfect Suite 8<img alt="Corel WP Suite 8"
width="16" height="16" border="0" align="top" src= 
"../Sielu/uudet_logot/pop-up-pieni.gif"></a></b> ja <a href= 
"javascript:uusikkunaa();" onmouseover="window.status='Pop-up\ \
-ikkuna;\ osoite:\ \
http://www.microsoft.com/finland/products/msoffice/';return true"
onmouseout="window.status='';return true"><b>MS Office 97</b><img
width="16" height="16" border="0" alt="MS Office 97" align="top"
src="../Sielu/uudet_logot/pop-up-pieni.gif"></a>
ohjelmistoista.</li>

In my mind Mozilla should not change the size of block when mouse goes over the top links in the English version:
http://www.nic.fi/~tapio1/Yleiset/Tecnical.html
2) Mozilla calculater margins to list elements differently as Opera and MS IE. I have not understand this and I'm not sure, which browser makes correct.
3) It crash easily in http://www.nic.fi/~tapio1/Yleiset/

I have made much as exact calculation as is possible from the monitor (it is impossible to make very exact calculation, because the pixes size varies).

Opera 5.01 and Mozilla 1.0 has fine horizontal calculation of block boxes. Mozilla calculates also vertical dimensions fine (Opera makes errors). 
MS IE 5.5 calculates serious way incorrectly.
I don't trust at all the calculations of MS but Opera is quite reliable.
When I think from this point of view, I can't understand why Opera and Mozilla calculates the left margin/padding of list elements differently

I recommend to install Mozilla, IF at least following matters work:
1) Mozilla doesn't hide any text in my CSS site
2) Mozilla doesn't cause drifting texts in my introduction pages.
3) It would not crash so easily

I would like to know, when Mozilla is worth to advertise.
Reporter, please report one problem per bug.  I would recommend filing separate 
bugs on each problem you mention in here and then marking this bug invalid.

This will probably be done whether or not you do it yourself, so I suggest that 
you do it, since you know which part of this report belongs to which bug that 
you mention.
One other comment.  Mozilla 0.6 is about 3 months old -- it's the Netscape 6.0 
codebase.  Please try a recent nightly.  There has been a number of fixes 
dealing with position:fixed since Mozilla 0.6, certainly.

Comment 3

18 years ago
Chnaging to style system
Component: Layout → Style System

Comment 4

18 years ago
changing owner
Assignee: clayton → pierre
QA Contact: petersen → chrisd

Comment 5

18 years ago
Marking Invalid.  Reporter, If you want to help with Mozilla, please learn how 
to write an efficient bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
whaa...?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.