crash on shockwave banner ad

VERIFIED DUPLICATE of bug 63243

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 63243
17 years ago
17 years ago

People

(Reporter: John Morrison, Assigned: av (gone))

Tracking

({crash, testcase})

Trunk
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Overview Description: 

  Surfing around, I hit a crash on a page at xml.com. After poking 
  around, I found that it was a shockwave animation, used as a banner
  ad on one of their pages. I've "captured" the html and the shockwave
  content at 
     http://jrgm.mcom.com/bugs/swf/crash.html

Steps to Reproduce: 
1) Load the above URL 

Actual Results:   crash
Expected Results: a byoootiful ad banner from IBM

Reproducibility: 100%

Build Date & Platform Bug Found: 20010104 win2k
Additional Builds and Platforms Tested On: 
                             none (plugins are platform specific, no?)

Additional Information: 

Stack trace from Talkback: 

0xffff034b 
npswf32.dll + 0xb904 (0x1000b904) 
npswf32.dll + 0xabd1 (0x1000abd1) 
USER32.DLL + 0x591b (0x77e1591b) 
USER32.DLL + 0x65a4 (0x77e165a4) 
ntdll.dll + 0x1fb83 (0x77f9fb83) 
nsView::SetDimensions [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 
606] 
nsViewManager2::ResizeView 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1688] 
nsLineLayout::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1112] 
nsInlineFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 604] 
nsInlineFrame::ReflowFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 413] 
nsInlineFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 329] 
nsLineLayout::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 922] 
nsBlockFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4364] 
nsBlockFrame::DoReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4248] 
nsBlockFrame::DoReflowInlineFramesAuto 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4182] 
nsBlockFrame::ReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4128] 
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3261] 
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2950] 
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1741] 
nsBlockReflowContext::DoReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 563] 
nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 335] 
nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3880] 
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3147] 
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2950] 
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1741] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
716] 
CanvasFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 309] 
nsBoxToBlockAdaptor::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 
870] 
nsBoxToBlockAdaptor::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 
526] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsScrollBoxFrame::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsScrollBoxFrame.cpp, line 
379] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsContainerBox::LayoutChildAt 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 596] 
nsGfxScrollFrameInner::LayoutBox 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
1030] 
nsGfxScrollFrameInner::Layout 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
1117] 
nsGfxScrollFrame::DoLayout 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
1038] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 788] 
nsGfxScrollFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
744] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
716] 
ViewportFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 
546] 
nsHTMLReflowCommand::Dispatch 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 
146] 
PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5106] 
ReflowEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4989] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 577] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 513] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 1055] 
nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 408] 
netscp6.exe + 0x167f (0x0040167f) 
netscp6.exe + 0x11b8 (0x004011b8) 
netscp6.exe + 0x2b48 (0x00402b48) 
KERNEL32.DLL + 0x7903 (0x77e87903)
(Reporter)

Comment 1

17 years ago
perfunctorily adding nsbeta1 keyword
Keywords: crash, nsbeta1, testcase
I can´t access your URL. (no DNS entry).
I think this is a dupe of bug 63243.
(Browser crashes on visiting any page with flash content)




*** This bug has been marked as a duplicate of 63243 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
This is a duplicate, verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.