The default bug view has changed. See this FAQ.

Email notifications from a blocked bug have the timestamp from its last change instead of the timestamp of the blocker

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Email Notifications
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: a.zhao, Assigned: Frédéric Buclin)

Tracking

(Blocks: 1 bug, {regression})

Bugzilla 4.0
regression
Dependency tree / graph
Bug Flags:
approval4.0 +
blocking4.0.1 +

Details

(Whiteboard: [4.0 only; trunk not affected])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 ( .NET CLR 3.5.30729)
Build Identifier: 4.0

My userbase started to complain about email notification recently. 

The scenario is like this, Bug A depends on bug B, and bug B on bug C, etc. The users are on the CC list of bug A. Now the status of bug C changes, and bugzilla will also notify all the CC list in bug A and bug B as well.  The only trouble: bug A itself has not changed, and the notification to CC list in A will carry the bug A's last time stamp. 

Because the Date: field of the email notification is the bug A's last update date (instead of bug C's update date), the notification will appear on user's email client as email from many many days ago. This makes user ignore the bugs potentially.

Is this a new feature of bugzilla 4? 

Reproducible: Always

Updated

6 years ago
Keywords: qawanted
I can confirm this.

I just got some bugmail dated Tue, 05 Oct 2010 17:33:20 +0000.

I got three messages for one change. The change was that bug 601715 had changed from open to resolved. Here's a bit more descriptive of what I got:

- The first listed was for bug 525513 with incorrect date given above and this content:

==== Start Quote ====
Bug 525513 depends on bug 601715, which changed state.

Bug 601715 Summary: Cleanup of migration code
https://bugzilla.mozilla.org/show_bug.cgi?id=601715

           What    |Old Value                   |New Value
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXED
==== End Quote ====

- The second listed was for bug 601374 which contained the same as the above email and also had an incorrect date.

- The third was for bug 601715 itself which was showing Sun, 24 Apr 2011 17:39:57 +0000. The content was:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Keywords|checkin-needed              |
             Status|ASSIGNED                    |RESOLVED
                 CC|                            |philip.chee@gmail.com
         Resolution|                            |FIXED
   Target Milestone|---                         |seamonkey2.1final
Blocks: 652325
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: x86 → All
(Assignee)

Comment 2

6 years ago
I fixed this problem on trunk in bug 396558, but this was a major code change to have everything going right. I will see how I can fix this problem for 4.0.1.
Flags: blocking4.0.1+
Target Milestone: --- → Bugzilla 4.0
Version: unspecified → 4.0
(Assignee)

Updated

6 years ago
Keywords: qawanted
Summary: Email notification for CC'ed users from a blocked bug carries wrong date → Email notifications from a blocked bug have the timestamp from its last change instead of the timestamp of the blocker
Whiteboard: [4.0 only; trunk not affected]
(Assignee)

Comment 3

6 years ago
Created attachment 528047 [details] [diff] [review]
patch for 4.0, v1

Subset of my patch from bug 396558.
Assignee: email-notifications → LpSolit
Status: NEW → ASSIGNED
Attachment #528047 - Flags: review?(wicked)
(Assignee)

Comment 4

6 years ago
Regression due to bug 452761.
Depends on: 452761
(Assignee)

Updated

6 years ago
Attachment #528047 - Flags: review?(dkl)
Comment on attachment 528047 [details] [diff] [review]
patch for 4.0, v1

Code looks fine and tests show that the Dates are now correct. r=dkl
Attachment #528047 - Flags: review?(dkl) → review+
(Assignee)

Comment 6

6 years ago
Thanks for the review. :)
Flags: approval4.0+
(Assignee)

Updated

6 years ago
Attachment #528047 - Flags: review?(wicked)
(Assignee)

Comment 7

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Bug.pm
modified Bugzilla/BugMail.pm
Committed revision 7579.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.