Link to Firefox 4.0 release notes missing

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Matthew Turnbull [Bluefang], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre
Build Identifier: 

I can't find a link to the Firefox 4.0 release notes anywhere. Usually it's linked right below wherever a download button can be found.

Reproducible: Always
I can confirm.

Also, many are looking for hardware acceleration requirements information as well.

Comment 2

7 years ago
Kind of related: bug 645028.

Comment 3

7 years ago
Hey guys. Sorry about the slow reply here. I'm wonfix'ing this bug b/c we made the decision to remove the release notes link from being below the download button...our research has shown that every extra link hurts conversion and there's not an overly huge demand for release notes.

Bottom line: I do think release notes are important, and should be made available, but I don't think this is the right place. We do have bug 647965 in the works to make sure all our What's New pages have a release notes link...that seems like a much better spot for that link.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

7 years ago
The point of this bug is that there is no link to the release notes _anywhere_ on the Mozilla site or from within Firefox.

I understand understand the whole thing with conversions and putting it in a more acceptable place. However, outright removing any trace of it, with out having an alternate/replacement ready or in place, should still not be considered acceptable.

It's been nearly 6 months and there is still no trace or mention of release notes anywhere.
Matthew: Release notes for the current version are available at http://www.mozilla.org/en-US/firefox/6.0.1/releasenotes/. There is a link to this page on the page that opens when you update Firefox (what we call the "whatsnew" page).
(Reporter)

Comment 6

7 years ago
I was under the impression that hasn't available since bug 647965 is still open. So it is linked somewhere.

But, that's still far from ideal. Getting to them requires downloading and installing the new release, then clicking a link on a page that only available once.

Maybe it's just me, but IMHO release notes are the kind of thing that should be made available _before_ you download and install a piece of software.

And if it's being linked to from the software, it should always be available somewhere (i.e. the about dialog), not just the first time you run it.
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.