-moz-box-flex does not work inside absolute/fixed position elements

RESOLVED DUPLICATE of bug 579776

Status

()

RESOLVED DUPLICATE of bug 579776
8 years ago
8 years ago

People

(Reporter: yoah, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

<head>
    <style>
        .box {
            display: -moz-box;
            display: -webkit-box;
            width: 350px;
            height: 300px;
            border: 5px solid red;
  			-moz-box-orient: vertical;
		    -webkit-box-orient: vertical;
         }
         .popup {
			position: fixed;
			top: 10px;
			left: 400px;
         }
        .top {
            background: green;
        }
        .flex {
            -moz-box-flex: 1;
            -webkit-box-flex: 1;
            background: cyan;
        }
        .bottom {
            background: orange;
        }
    </style>

</head>
<body>
    <div class="box">
        <div class="top">Top</div>
        <div class="flex">flex</div>
        <div class="bottom">Bottom</div>
    </div>


    <div class="popup box">
        <div class="top">Top</div>
        <div class="flex">flex</div>
        <div class="bottom">Bottom</div>
    </div>

</body>

The left flex box is sized well, but the right one, which is in a popup, is not. Works well in webkit.

Reproducible: Always

Steps to Reproduce:
1. Open the test page and observe sizes of flex box (middle one)

Actual Results:  
Sizes on both sides differ

Expected Results:  
Same sizes of flex box
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre ID:20110322030409

Behaviour differs from Chrome 11.0.696.16 dev.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
"position:fixed" forces display to "block".  So then you don't get box behavior, of course.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579776
You need to log in before you can comment on or make changes to this bug.