Unable to type in quick reply box on a forum




7 years ago
2 years ago


(Reporter: JonClaw89, Unassigned)



Windows 7

Firefox Tracking Flags

(Not tracked)




(1 attachment)



7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

When attempting to type into a quick reply box on a particular forum (URL included), no insertion point appears. I'm unable to type in the textbox. Worked fine on FF 3.6

Reproducible: Always

Steps to Reproduce:
1. Go to URL included
2. Go to any thread.
3. Try clicking on the quick reply box.
4. No insertion point appears, cannot type.
Actual Results:  
I'm unable to type in the box.

Expected Results:  
An insertion point should have appeared and I should have been able to type.

It is possible that the quick reply box not being a plain text editor has something to do with this bug?

Worried this might affect other sites.
I can't see the quickreply box without a login, so I'll have to create one when I get a sec.

In the meantime, are there any error shown in the error console (just errors, not warnings) - press ctrl+shift+J to view.

Could you see if the issue occurs if using Firefox in safe mode:

How about with a new, empty testing profile? (Don't install any addons into it)
Keywords: regression, regressionwindow-wanted
Version: unspecified → Trunk

Comment 2

7 years ago
Safe mode, old profile: No change
Not safe mode, new profile: Problem fixed

One error shows up when using my old profile:
Error: editor.attachEvent is not a function
Source File: http://www.federalsoup.com/RTE_javascript.asp?textArea=message&QR=true
Line: 23
Thanks for the update.

Using your old profile, please clear cache and cookies using ctrl+shift+del, "everything" + tick cache and cookies - and see if that fixes the problem.

Failing that, please attach the contents of about:support into a txt file and attach it to this bug using the add an attachment link above.
Keywords: regression, regressionwindow-wanted

Comment 4

7 years ago
No change after clearing the cache and cookies.

Attaching the txt file now.

Comment 5

7 years ago
Created attachment 521164 [details]
About:Support file for Bug 644029
Reporter, please can you confirm whether this issue still occurs using Firefox 4.0.1 (http://www.mozilla.com/firefox/new/) or higher, in Firefox safe mode (http://support.mozilla.com/kb/Safe+Mode) and/or with a clean profile (http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile). Ideally, also check using the latest nightly: http://nightly.mozilla.org/

If this issue no longer occurs, please close as "Resolved Worksforme".

It it in fact still occurs, please provide as much extra information as possible, including what versions tried, whether safe mode/new profile tested etc. Thanks! :-)

(Template reply to inactive UNCO bugs)

Comment 7

7 years ago
Not fixed under Firefox 4.0.0 or 4.0.1.

Tried safe mode and safe mode with a new profile.

Comment 8

7 years ago
does editor.attachEvent is not a function still occur in newer versions?
Keywords: regression

I created a new username on https://forum.federalsoup.com/ . I tried to leave a comment, but I was unable to because they currently have a problem and some users can't post ("We are aware of an issue with members being unable to posts to threads because their membership is not yet approved or their memberships keeps reverting back to unapproved." - https://forum.federalsoup.com/default.aspx?g=posts&t=71633#post788774).

Is this still reproducible on your end? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results?

Thank you.
Flags: needinfo?(JonClaw89)
Whiteboard: [closeme 2016-04-11]
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Last Resolved: 2 years ago
Flags: needinfo?(JonClaw89)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-04-11]
You need to log in before you can comment on or make changes to this bug.