middle mouse click on a link opens two tabs (and more)

RESOLVED INCOMPLETE

Status

()

Firefox
Tabbed Browser
RESOLVED INCOMPLETE
7 years ago
7 years ago

People

(Reporter: Flo84, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

when you click a hyperlink with the middle mouse button, usually a new tab opens and the page is loading (that was the case in the previos versions of firefox). if you do this in firefox 4 (for example on a google search result), two and more tabs opens.

Reproducible: Always

Steps to Reproduce:
1. go to google.com and search for something
2. click (and hold for 1 - 2 seconds) a result link with the middle mouse button
3. see what happens: 2 and more tabs are going to open
Actual Results:  
see "steps to reproduce"

Expected Results:  
only one tab should open

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre

Works fine for me. Does the issue still occur if you start Firefox in Safe Mode?
http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Flo, do you have NoScript installed? Does disabling it solves the issue?
Version: unspecified → Trunk
(Reporter)

Comment 3

7 years ago
Interresting thing: after starting Firefox in Safe Mode, the same problems occured. Then I started Firefox in Normal Mode and now everything works just fine - strange thing, I didn't deactivate any addon (only DownThemAll and the WebDeveloper addon is installed on my system). I just installed the new version on another system with the same addons, but there are no problems with the tabs. The only difference: I removed the old Firefox version before I installed the new one. Either it's an installation problem when you install the new version without removing the old verion before installing the new one or it has something to do with the profile. Anyway starting Firefox in SafeMode and restarting it in "Normal Mode" fixed the problem for me. Sorry, it seems that it isn't a bug, sholud have discussed this in a forum / newsgroup. Thanks for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → INCOMPLETE

Updated

7 years ago
Duplicate of this bug: 644432
You need to log in before you can comment on or make changes to this bug.