Closed Bug 644086 Opened 10 years ago Closed 10 years ago

"See More Add-ons" button should not show if there are no more addons to see

Categories

(Firefox for Android Graveyard :: General, defect, P2)

ARM
Android
defect

Tracking

(fennec-)

VERIFIED FIXED
Tracking Status
fennec - ---

People

(Reporter: andreea.pod, Assigned: wesj)

Details

(Keywords: regression, Whiteboard: [fennec-4.1?])

Attachments

(1 file, 2 obsolete files)

Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre Fennec /4.1a1pre

Steps to reproduce:
1. Go to Preferences > Add-ons
2. Pan down to the bottom of the panel
3. Click on the "See more add-ons" button

Expected result:
5 more extensions or themes that matches your search will be displayed and the button will not be present anymore.

Actual result:
Nothing happens. 

Note:
Might be regression of Bug 596594.
Work for me on 03/28 nightly (querying took about five seconds). With a recent nightly are you able to reproduce?
This works on 4.0, so must be a regression since it went to 4.1pre
tracking-fennec: --- → ?
Keywords: regression
Priority: -- → P2
For me it is still reproducible on build: Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre Fennec /4.1a1pre 
Device: HTC Desire (Android 2.2)
This issue is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.2a1pre)Gecko/20110329
Firefox/4.2a1pre Fennec /4.1a1pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
Assignee: nobody → wjohnston
tracking-fennec: ? → 2.0-
Whiteboard: [fennec-4.1?]
Attached patch Patch v1 (obsolete) — Splinter Review
I think there's a couple little problems with our logic in deciding whether to show this button or not. This changes the logic so that it is based on which browsable addons were actually added (i.e. weren't recommended) and on whether or not those were actually hidden.
Attachment #524503 - Flags: review?(mark.finkle)
Comment on attachment 524503 [details] [diff] [review]
Patch v1

Do we need to return the array of add-ons? Or can we just return the number of add-ons that were appended?
Attached patch Patch v2 (obsolete) — Splinter Review
Yeah. Or we could just return a boolean like this. The possibilities are endless.
Attachment #524542 - Flags: review?(mark.finkle)
Comment on attachment 524503 [details] [diff] [review]
Patch v1

I like this one, except make appendedAddons be a count
Attachment #524503 - Flags: review?(mark.finkle) → review+
Attachment #524542 - Flags: review?(mark.finkle) → review-
Attachment #524503 - Attachment is obsolete: true
Attachment #524542 - Attachment is obsolete: true
Attachment #524664 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/760c50e2239a
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I cannot validate this bug because the button "See more add-ons" is not present in the Add-ons panel anymore.

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110413 Firefox/5.0a2 Fennec /5.0a2

Reopening the bug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The issue was that the button was being shown when it shouldn't have been. The fact that it is not showing means that this is fixed and that this aspect of the button is "working".

I'll rename the bug if that helps.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Summary: "See More Add-ons" button is not working on nightly build → "See More Add-ons" button should not show if there are no more addons to see
Anna - Do you have any add-ons installed? Are there any add-ons listed in the "Get Add-ons" section?
I tested in both cases:

a) On a clean build with no add-ons installed. In this case I get 8 recommended addons and no "See more add-ons" button. 

b) On a clean build, I installed all the 8 recommended add-ons. In the "Get Add-ons" section, there are no more recommended add-ons, only a "Try Again" button.

I've made a video: first device: Motorola Droid 2 (Android 2.2)- case a)
                   second device: HTC Desire Z (Android 2.2) -case b)

http://www.youtube.com/user/qaioana#p/u/0/QYPy6wIytoU

Hope it helps ...
As far as I know, those are both the intended behaviors. pinging Madhava to make sure
(In reply to comment #15)
> As far as I know, those are both the intended behaviors. pinging Madhava to
> make sure

Not exactly.

(In reply to comment #14)
> I tested in both cases:
> 
> a) On a clean build with no add-ons installed. In this case I get 8 recommended
> addons and no "See more add-ons" button. 

You should see a "Show More" button since we also pull down extra, popular add-ons. We do not limit the list to only recommended add-ons. Only if the extra list of add-ons returns zero _and_ there are only 8 recommended add-ons would the "Show More" button be hidden.

> b) On a clean build, I installed all the 8 recommended add-ons. In the "Get
> Add-ons" section, there are no more recommended add-ons, only a "Try Again"
> button.

Again, the "Show More" button should be visible unless there are zero extra add-ons available.

NOTE: Why might there be zero extra add-ons? If you are using a bleeding edge Fennec (5.0a2 or 6.0a1 for example), you might not see any extra add-ons and very few recommneded add-ons simply because there are no add-ons that are compatible with the bleeding edge version of Fennec.
> 
> NOTE: Why might there be zero extra add-ons? If you are using a bleeding edge
> Fennec (5.0a2 or 6.0a1 for example), you might not see any extra add-ons and
> very few recommneded add-ons simply because there are no add-ons that are
> compatible with the bleeding edge version of Fennec.

Yes, that might have been the case. I was testing on 

Build ID: Mozilla/5.0 (Android;Linux armv7l;rv:5.0a2)Gecko/20110415 Firefox/5.0a2 Fennec /5.0a2
verified FIXED On build:
Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 Fennec/6.0a1 ID:20110421043148
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.