All users were logged out of Bugzilla on October 13th, 2018

Ugly font rendering with hardware acceleration

RESOLVED DUPLICATE of bug 635490

Status

()

--
major
RESOLVED DUPLICATE of bug 635490
8 years ago
7 years ago

People

(Reporter: niels.nwx, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

All text in all fonts look ugly, burry, blockish, aliased... hard to describe exactly. Reading it is difficult and gives you a headache. Please look at the picture to see more clearly what I mean.

Settings gfx.direct2d.disabled to true or disabling hardware acceleration in the options fixes it.

Reproducible: Always

Steps to Reproduce:
1. Use firefox with normal settings. Don't know if all environments are affected.
Actual Results:  
Ugly hard-to-read font which gives you severe headaches.

Expected Results:  
Nice font that's readable without giving you a headache.

Related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=594325
https://bugzilla.mozilla.org/show_bug.cgi?id=613848
However one of these is closed and the others don't accurately show the font I see.

I see some people suggesting a hotfix for Windows (included in SP1 for Windows 7) fixes it. I have Windows 7 SP1 and it is not fixed.

Setting gfx.font_rendering.directwrite.enabled to false does not fix it like some claim.

I see some claim that using the ClearType tuning tool included in Windows 7 fixes it: it doesn't.

I also see some claiming that this is normal behavior for the font writing in direct2D. If that is the case than hardware acceleration should be disabled by default. It isn't acceptable to have to read text like that.

More info:
https://support.mozilla.com/nl/questions/793856
http://support.mozilla.com/en-US/questions/791489
http://forums.mozillazine.org/viewtopic.php?f=23&t=2060933&sid=ff9613c64d4a9cb2bda4ecd6ea7f65c1
(Reporter)

Comment 1

8 years ago
Created attachment 521143 [details]
ugly font example
(Reporter)

Comment 2

8 years ago
Created attachment 521144 [details]
normal font with gfx.direct2d.disabled to true

Updated

8 years ago
Blocks: 635490
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Isn't this bug a dupe of bug #635490 ?
If yes, please mark this as DUPLICATE.

Comment 4

7 years ago
It is, please mark it as DUPLICATE.

Comment 5

7 years ago
Thanks for confirming Adam :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 635490
You need to log in before you can comment on or make changes to this bug.