giop_thread_request_push: assertion `tdata != NULL' failed (one of mochitests)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: tompelka, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-2011-05-06])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Red Hat/3.6.13-2.el6_0 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Red Hat/3.6.13-2.el6_0 Firefox/3.6.13

31893 INFO Running /tests/content/events/test/test_bug456273.html...
WARNING: giop_thread_request_push: assertion `tdata != NULL' failed: 'glib warning', file nsSigHandlers.cpp, line 210

** (<unknown>:2295): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed

TEST-UNEXPECTED-FAIL | automation.py | Exited with code -11 during test run
INFO | automation.py | Application ran for: 0:05:58.586679
INFO | automation.py | Reading PID log: /tmp/tmpBhn6yNpidlog
==> process 1055 launched child process 2295
INFO | automation.py | Checking for orphan process with PID: 2295
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.

INFO | runtests.py | Running tests: end.
make[1]: *** [mochitest-plain] Error 245

Seems like crash, because the test stops and does not continue. 

Reproducible: Always

Steps to Reproduce:
1. Run mochitest make mochitest-plain
2.
3.
Actual Results:  
See details.

Expected Results:  
No fail.

Seems to be relevant to bug456273, which should be fixed.

Comment 1

8 years ago
Reporter, are you able to reproduce this with a current Firefox?
Whiteboard: [bugday-2011-05-06]
(Reporter)

Comment 2

8 years ago
Not able to reproduce on 3.6.17, BUT the thing is that I'm not able to run any mochitest right now.

Executing like:
python runtests.py --timeout=660 --log-file=some_log.file --file-level=DEBUG --autorun --close-when-done --console-level=FATAL --appname=/usr/lib*/firefox-*/firefox 

uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: ./httpd.js :: anonymous :: line 495"  data: no]

Already filed as Bug 654098.

This is actually blocking me to reproduce Bug 644099.
(Reporter)

Updated

8 years ago
Blocks: 654098

Updated

7 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 3

6 years ago
Not able to reproduce on 17 branch, I would propose to close.

Comment 4

5 years ago
(In reply to tompelka@gmail.com from comment #3)
> Not able to reproduce on 17 branch, I would propose to close.

Ok :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.