Navigation bar bugged out

RESOLVED DUPLICATE of bug 643792

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED DUPLICATE of bug 643792
7 years ago
7 years ago

People

(Reporter: Benjamin Jay Young, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

I added the mozzilateam stabe ppt to APT, and let Ubuntu install firefox 4 for me. It started up fine, but when I clicked "customize" on the the Navigation bar, I moved the Home button and a few things around. After I closed the custimization window, all of my toolbar menus were left up, and I couldn't close them by checking and unchecking them. So, I restarted firefox, and once firefox loaded back up, by Navigation bar is "there", but all the buttons and inputs are gone from it. I customized it again, added everything back to it (which the reload and refresh buttons seem to now be smaller), and had everything back. When I restarted Firefox again, everything was gone again. I repeated my steps again, and I get the same results each time firefox restarts, which makes the browser completely unusable until I fix it everytime after I open firefox.

Reproducible: Always

Steps to Reproduce:
1. See Details.


Expected Results:  
Have a functional navigation bar, so I can navigate the Internet.

Comment 1

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Hey Benjamin and thanks for the report. So far I am unable to reproduce the issue you have logged. Can you please try it on a clean profile:
http://support.mozilla.com/en-US/kb/Managing%20profiles
Version: unspecified → Trunk
Can you check bug 643792 and see if it matches what you are seeing please.
Also, do you have the Google Toolbar addon installed?
Component: General → Toolbars
Keywords: regression
QA Contact: general → toolbars
(Reporter)

Comment 3

7 years ago
Created attachment 521368 [details]
Screen shot

Here's a screen shot. As you can see the Navigation bar is "there", but all the buttons have disappeared.
(Reporter)

Comment 4

7 years ago
Bug 643792 is actually the same exact problem I encounter right after customize, but does not go on about the second part of my problem (see screen shot attached). I do have Google Toolbar installed. I will try and clean the profiles as instructed, and will post my results.
(Reporter)

Comment 5

7 years ago
I cleared the profiles as instructed, and then continued on to do the exact procedures I did before. They worked fined and even after restarting the browser, everything was still fine. I can continue on to re-enable any of my add-ons, then try again, to see if this could be the cause of this problem?
Yes that would be great. Perhaps start with the Google Toolbar addon.
(Reporter)

Comment 7

7 years ago
I reinstalled Google Toolbar, still worked fine. I went ahead and installed all the add-ons I remember having, including Firebug, Colorzilla, Web Developer Toolbar, NoScript, and iMacros. I'm no longer able to reproduce either bugs.
(Reporter)

Comment 8

7 years ago
False alarm. I went back in to customization and checked the smaller icons, to see what it would look like, once I closed the window, I experienced both bugs again. I will try manually disabling each add-on, one by one, and post my results.
(Reporter)

Comment 9

7 years ago
I'm almost certain now it's Google Toolbar. With it enabled, sometimes merely just going in to custimzation, or making the buttons a different size, either by checking the "smaller buttons" box or boxing a button from a smaller toolbar to a larger one. This doesn't have any of the same effects when Google Toolbar is disabled, I've tried multiple times doing different things. It appears as well I'm not able to hover on to my right click menu without it disappearing. Also, after leaving the custimization screen and having Bug 643792 occur, I notice Google Toolbar is the only toolbar uneffected by missing buttons.

I'm going to clear my profile again, so I can get my GUI back to normal, but at least now I'm able to effectivly create both of these bugs and know somewhat the cause. If you need any further information, I can provide you with videos, images, or plain text.
Thanks for the extra info. I'm going to dupe this to bug 643792 given they are caused by the same thing (and the other bug was logged first), but will make sure I indicate that this bug should be looked at for the wealth of additional information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 643792
Resolution: --- → DUPLICATE
Duplicate of bug: 643792
You need to log in before you can comment on or make changes to this bug.