Closed Bug 644162 Opened 9 years ago Closed 3 years ago

Hebrew fonts problem - some of the headlines are shown with other font

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1119619

People

(Reporter: trytomemorize, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Hey, (It's only began after I upgraded to 4 )
site for example :
http://www.calcalist.co.il/internet/articles/0,7340,L-3512272,00.html 

Screenshots:
http://img190.imageshack.us/i/firefox4d.png/
http://img844.imageshack.us/i/ie8b.png/ 

Reproducible: Always




Thanks.
Is your Issue reproducible when you disable the Hardware Acceleration and restart Firefox?
If yes, please post the Content of the Graphics Section you can get via "about:support" after you re-enabled Hardware Acceleration.
Version: unspecified → Trunk
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
bug verified here.
fixed by turning off hardware acceleration!
about:support output:


  Application Basics

        Name
        Firefox

        Version
        4.0

        User Agent
        Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Password Exporter
        1.2.1
        true
        {B17C1C5A-04B1-11DB-9804-B622A1EF5492}

        Java Console
        6.0.24
        true
        {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}

        Firebug
        1.7.0
        true
        firebug@software.joehewitt.com

        Adblock Plus
        1.3.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110318052756

        browser.startup.homepage_override.mstone
        rv:2.0

        browser.tabs.warnOnClose
        false

        extensions.lastAppVersion
        4.0

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1300976615

        places.history.expiration.transient_current_max_pages
        64396

        privacy.cpd.siteSettings
        true

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce GT 430

        Vendor ID
        10de

        Device ID
        0de1

        Adapter RAM
        1024

        Adapter Drivers
        nvd3dum nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17563, font cache n/a)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 10
Hey , When I turned off the Hardware Acceleration  it's fixed the problem,
This is when the Hardware Acceleration is on:
 


  Application Basics

        Name
        Firefox

        Version
        4.0

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        YouTube mp3
        1.0.2
        false
        info@youtube-mp3.org

        User Agent Switcher
        0.7.3
        true
        {e968fc70-8f95-4ab9-9e79-304de2a71ee1}

        Java Console
        6.0.20
        true
        {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

        Java Console
        6.0.21
        true
        {CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}

        Java Console
        6.0.22
        true
        {CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}

        Conduit Engine
        3.3.3.2
        true
        engine@conduit.com

        Tab Mix Plus
        0.3.8.5
        true
        {dc572301-7619-498c-a57d-39143191b318}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.history_expire_days.mirror
        180

        browser.link.open_newwindow.restriction
        0

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://search.conduit.com/?ctid=CT2790392&SearchSource=13

        browser.startup.homepage_override.buildID
        20110318052756

        browser.startup.homepage_override.mstone
        rv:2.0

        browser.tabs.warnOnClose
        false

        extensions.lastAppVersion
        4.0

        keyword.URL
        http://search.conduit.com/ResultsExt.aspx?ctid=CTXXXX&q=

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1301062847

        places.history.expiration.transient_current_max_pages
        112665

        places.last_vacuum
        1297323410

        print.print_printer
        Brother HL-2030 series

        print.printer_Brother_HL-2030_series.print_bgcolor
        false

        print.printer_Brother_HL-2030_series.print_bgimages
        false

        print.printer_Brother_HL-2030_series.print_command

        print.printer_Brother_HL-2030_series.print_downloadfonts
        false

        print.printer_Brother_HL-2030_series.print_edge_bottom
        0

        print.printer_Brother_HL-2030_series.print_edge_left
        0

        print.printer_Brother_HL-2030_series.print_edge_right
        0

        print.printer_Brother_HL-2030_series.print_edge_top
        0

        print.printer_Brother_HL-2030_series.print_evenpages
        true

        print.printer_Brother_HL-2030_series.print_footercenter

        print.printer_Brother_HL-2030_series.print_footerleft
        &PT

        print.printer_Brother_HL-2030_series.print_footerright
        &D

        print.printer_Brother_HL-2030_series.print_headercenter

        print.printer_Brother_HL-2030_series.print_headerleft
        &T

        print.printer_Brother_HL-2030_series.print_headerright
        &U

        print.printer_Brother_HL-2030_series.print_in_color
        true

        print.printer_Brother_HL-2030_series.print_margin_bottom
        0.5

        print.printer_Brother_HL-2030_series.print_margin_left
        0.5

        print.printer_Brother_HL-2030_series.print_margin_right
        0.5

        print.printer_Brother_HL-2030_series.print_margin_top
        0.5

        print.printer_Brother_HL-2030_series.print_oddpages
        true

        print.printer_Brother_HL-2030_series.print_orientation
        0

        print.printer_Brother_HL-2030_series.print_pagedelay
        500

        print.printer_Brother_HL-2030_series.print_paper_data
        9

        print.printer_Brother_HL-2030_series.print_paper_height
        11.00

        print.printer_Brother_HL-2030_series.print_paper_size_type
        0

        print.printer_Brother_HL-2030_series.print_paper_size_unit
        1

        print.printer_Brother_HL-2030_series.print_paper_width
        8.50

        print.printer_Brother_HL-2030_series.print_reversed
        false

        print.printer_Brother_HL-2030_series.print_scaling
        1.00

        print.printer_Brother_HL-2030_series.print_shrink_to_fit
        true

        print.printer_Brother_HL-2030_series.print_to_file
        false

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_bottom
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_left
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_right
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_top
        0

        privacy.cpd.extensions-tabmix
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        3

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        ATI Radeon HD 4250

        Vendor ID
        1002

        Device ID
        9715

        Adapter RAM
        512

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.762.0.0

        Driver Date
        8-3-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7600.16385, font cache n/a)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 10
This is probably the same underlying issue as bug 584769.
Depends on: 584769
I believe this is the same issue as described (again) in bug 1119619, and the patch just landed there will resolve it; dup'ing forward to the new bug where the fix is happening.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119619
You need to log in before you can comment on or make changes to this bug.