Closed Bug 644255 Opened 11 years ago Closed 11 years ago

FF3.6.16 firstrun/whatsnew page tells PPC users to get "latest and greatest FF4" even though FF4 does not support PPC

Categories

(www.mozilla.org :: General, defect)

x86
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cww, Assigned: jlong)

References

Details

Attachments

(3 files)

After PPC users get 3.6.16, the whatsnew page suggests they update to the latest Firefox (4) which they can't run. After they install, they're in a situation where Firefox won't start.
Summary: Firefox 4 being offered to PPC users on 3.6.16 firstrun/whatsnew page → FF3.6.16 firstrun/whatsnew page tells PPC users to get "latest and greatest FF4" even though FF4 does not support PPC
fixed on trunk r86254
pushed to stage r86256

http://www-trunk.stage.mozilla.com/en-US/firefox/3.6/whatsnew/
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: qawanted
Resolution: --- → FIXED
Duplicate of this bug: 644257
removed the upgrade message under the title in r86258
qa-verified-trunk www-trunk.stage.mozilla.com/en-US/firefox/3.6/whatsnew

using Mozilla/5.0(Macintosh U;PPC Mac OS X 10.5; en-US; rv 1.9.2.15)
pushed to production r86269
Assignee: nobody → jlong
This still seems to be happening.  See bug 644438 comment #6.

I'm testing on a Mac G4 running OS X 10.4.11.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #6)
> This still seems to be happening.  See bug 644438 comment #6.
> 
> I'm testing on a Mac G4 running OS X 10.4.11.

Steven,

Can you go to http://whatsmyuseragent.com/ and paste your User-Agent here?
FF 3.6.16 user-agent string:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

FF 3.5.18 user-agent string:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.18) Gecko/20110319 Firefox/3.5.18
Thanks Steven! I'm having trouble reproducing the problem. Are you looking at the following URL?

http://www.mozilla.com/en-US/firefox/3.6/whatsnew/

I used your exact UA string and I got the minimal version of the page without the promos.
I just tested again, and in the last few minutes the problem with FF 3.6.16 seems to have gotten fixed!

It's still happening with FF 3.5.18, though.
> I just tested again, and in the last few minutes the problem with FF 3.6.16
> seems to have gotten fixed!

Now the previous bad behavior is back.
Duplicate of this bug: 644438
The patch uses php to detect the user agent but our pages are cached after generation as static html for performance reasons. The page should either be sent with http headers disabling caching for the page or the UA sniffing should be done client-side in javascript.
See also: bug 643783
Anything left to do here?
This bug is pretty high priority. Need a fix by Friday.
Tracking number of impacted PPC users in bug#644648.
I (In reply to comment #15)
> The patch uses php to detect the user agent but our pages are cached after
> generation as static html for performance reasons. The page should either be
> sent with http headers disabling caching for the page or the UA sniffing should
> be done client-side in javascript.

Pascal makes a good point, and that's probably why it was sporadic before. I implemented it in javascript in:

r86838 on trunk

Please retest.
Keywords: qawanted
We  need fallback when Javascript is  disabled as the link to upgrade to Firefox 4 is currently shown do users with that pref off
Keywords: qawanted
We can't have a real fallback with JS deactivated. Those pages are cached so we can't rely on PHP to determine which browser is visiting. When JS is disabled, download buttons across the whole site just display links to the three platforms.
Raymond, since we can't do anything about users with javascript disabled, does this fix work?
Yes it does..
pushed to stage r86843
pushed to production r86845
r86861 for locales on production (also deals with other download boxes for locales), I think we can close this bug now.
Thanks pascal!
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
I just tested again, with FF 3.6.16 and 3.5.18 on my PPC G4 Mac running OS X 10.4.11.  The problem is fixed in FF 3.6.16, but still exists in FF 3.5.18 -- in it I still see the "bad" whatsnew page of attachment 521521 [details].

Should I open a new bug?
Thanks Steven. If you don't mind, create a new bug that is for implementing this fix across all of our 3.* whatsnew pages. This was only done in 3.6.
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.