Last closed tab is restored if download manager is open

VERIFIED DUPLICATE of bug 628043

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 628043
7 years ago
7 years ago

People

(Reporter: dvkpdq, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0

When download manager is open and user closes the last window (therefore closing the last tab too), the closed tab is restored when user opens a new window.

Reproducible: Always

Steps to Reproduce:
1. Open one window with one tab in it. Load any website.
2. Open download manager
3. Close the window
4. Open a new window
Actual Results:  
Website from closed one is restored in the new window.
Also when firefox is started with URL given via command line, it opens website it was asked to open AND restores one from the closed window (in two tabs).

Expected Results:  
Start home page.
In the second case: only URL from command line should be opened.

This does not happen if the last tab is closed directly (not by closing whole window) or when the last tab has nothing loaded in it.
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Reporter)

Comment 1

7 years ago
Additional info:
The download manager should be downloading something to prevent it from closing when the last window is closed.

A moment ago my friend has reported that the same situation occurs with multiple tabs.

Comment 2

7 years ago
I can confirm this bug.

Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20110321 Firefox/4.0

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628043
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.