TJPzoom 3 image zoomer script does not work in Firefox 4

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Other
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: Fernando Polito, Unassigned)

Tracking

({regression, testcase})

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When the pointer is over the picture the magnmifier apears and folow the pointer.

Reproducible: Always

Steps to Reproduce:
1.Open the URL http://valid.tjp.hu/tjpzoom/index_en.html
2.point the pointer over the picture.
3.
Actual Results:  
The picture disapear completly



Expected Results:  
A magnifier show a piece of picture zoomed
The relevant Script is on http://valid.tjp.hu/tjpzoom/tjpzoom.js
No Idea if this intended or not.

Reporter, if you want to help further you can find a Regression Range using e.g. http://harthur.github.com/mozregression/
Keywords: regressionwindow-wanted
Version: unspecified → Trunk
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110323 Firefox/4.2a1pre ID:20110323074443.

Last good nightly: 2010-02-06 
First bad nightly: 2010-02-08

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=173248959f01&tochange=05c983938253

There is no win32 2010-02-07 nightly, so the range is unfortunately still 48hrs.

Peter, since a few of the DOM related changesets in that range were assigned to you, thought you might be able to suggest what is causing this? Thanks!
Status: UNCONFIRMED → NEW
Component: General → DOM
Ever confirmed: true
Keywords: regressionwindow-wanted → regression, testcase
Product: Firefox → Core
QA Contact: general → general
Hardware: x86_64 → x86
Summary: The magnifier implemented in that URL doesn't work like in the FF3.6 → TJPzoom 3 image zoomer script does not work in Firefox 4
This is fallout from bug 374216, and a bug in the page that needs to be fixed by the page author.  The page has this wonderful code:

 if(typeof(TJPstage.style.filter) != typeof(nosuchthing)) {
  //hi IE
  if(navigator.appVersion.indexOf('Mac') == -1) { //hi Mac IE
   TJPstage.style.filter='alpha(opacity=0)';
   TJPstage.style.backgroundColor='#ffffff';
  }
 } else {
  //hi decent gentlemen
  TJPstage.style.backgroundImage='transparent';
 }

Now style.filter is an SVG filter in Firefox 4, so its type is not undefined.  And you're not on Mac, so you get the background color set to white instead of transparent (not that 'transparent' is a valid value for backgroundImage).  And at the same time "alpha(opacity=0)" is not a valid value for an SVG filter, so gets ignored.

The result is that you get white instead of transparent.

Oh, and the bug doesn't appear on Mac, of course, due to the code above.
Assignee: nobody → other
Blocks: 374216
Component: DOM → Other
Product: Core → Tech Evangelism
QA Contact: general → other
Version: Trunk → unspecified
I mailed the script author.
Thanks again Boris :-)

(Another case of the more time I spend on BMO, the more I realise I don't know!)
(Reporter)

Comment 6

7 years ago
Dear developers,
Let me know, this bug will be fixed in the FF4 code or it should be fixed in the page code?

Comment 7

7 years ago
(In reply to comment #6)
> Let me know, this bug will be fixed in the FF4 code or it should be fixed in
> the page code?

See comment 3; this needs to be fixed by the site author.

cl
Hardware: x86 → All

Comment 8

7 years ago
Boris, thanks for the heads-up. And shall I express my discontent with myself of not being futureproof enough four years ago when I last touched it. Fixed and now works fine on FF win again.
But, as always, there's a caveat, I'm not sure (and don't have a vista box) what it does nowadays with ie9 - can someone give me a hand w/ testing on valid@tjp.hu?
Confirm fixed after ctrl+F5ing using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110323 Firefox/4.2a1pre ID:20110323161246.

(In reply to comment #8)
> can someone give me a hand w/ testing on valid@tjp.hu?

Sure, email sent. (tldr; works in IE9)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
OS: Windows Vista → All
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.