Closed Bug 644345 Opened 9 years ago Closed 9 years ago

windows are not rendered if firefox is on another than the main screen with multi monitor setups

Categories

(Firefox :: General, defect, major)

4.0 Branch
x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 632749

People

(Reporter: ap, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

If 2 screens are used and firefox is on the none main screen, things like open new window or view source will not show a new window. The Window is simply not shown, but there is a entry in the "Windows" menu for it. Same goes for the download window.Moving FF back to the mainscreen and doing the same works flawlessly. 

With this bug, using FF with multiple screens is useless at the moment.

Reproducible: Always

Steps to Reproduce:
1. Open FF
2. Move it to the second screen
3. Try to view source, download something or make a new window
Actual Results:  
nothing shows up

Expected Results:  
new window appears
This is also being discussed in the support area:

http://support.mozilla.com/en-US/questions/803320
Version: unspecified → 4.0 Branch
Confirmed in Mac OS X 10.6.8. This is a showstopper for me.
I found a little workaround, you can align the screens both in a line on top and it will work, but this sucks if you have 2 diffrent ones like me. I switched to another brwoser until this gets fixed proper.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 632749
You need to log in before you can comment on or make changes to this bug.