Intranet tab performance, stability and usability problems

RESOLVED INVALID

Status

SeaMonkey
Sidebar
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: johng, Unassigned)

Tracking

({perf})

1.0 Branch
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
To reproduce:

* Netscape 6 final public release on Win 95
* Add the last My Sidebar tab (add bug/LXR/phonebook panel) linked on Scott
Collins web page at http://scottcollins.net/journal/
* Use the phone book feature of this tab repeatedly, typing in a name and
pressing enter (note that this uses a Netscape intranet phonebook inside the
firewall).

This is my most used tab (thanks Scott!) and it has problems that demonstrate
some performance, stability and UI problems that we have.  Not sure if the
problem is purely client, purely server, or a combo.  This might be a great test
case for us to improve the performance, stability and usability of My Sidebar in
general.

Here are the problems:

* Performance: Sometimes, not always, extremely slow.
Type the name, press enter, and sometimes the results come quickly.  Othertimes,
seemingly always the first time this is used during a session, their is a long
delay.

* Stability/ Reliability: Sometimes, not always, no response/ does not work.
Do the same thing as above, and sometimes, seemingly more often the first time
used during a session, nothing ever happens.  It is as if you never pressed
return, or if the client tried and then just gave up.  I notice that during the
time it works but very slowly, the client seems to freeze with the cursor not
flashing (freeze can become a stability issue).  In the nothing happens
scenario, the cursor continues to flash like I never pressed enter.

* Usability: While working, there is no user feedback.
During the scenario when it is working but extremely slow, there is no cursor or
any other kind of feedback (like the N flashing or something in the Sidebar
indicating that something is happening).  So the user has no idea if he should
press enter again or just sit there and wait.

Assigned this to Scott since he created the tab and cares a great deal about
performance and stability.

Comment 1

17 years ago
I don't know when I'll get to this.  Strings are taking priority.  If anyone
wants to look, feel free to take the bug from me.
Status: NEW → ASSIGNED
Whiteboard: HELP WANTED
Target Milestone: --- → Future

Updated

17 years ago
Keywords: helpwanted
Whiteboard: HELP WANTED → HELPWANTED

Comment 2

17 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Updated

17 years ago
Keywords: perf
Product: Browser → Seamonkey
NS6.0 is not our product.

<http://scottcollins.net/journal/>
gives
{{
The document /journal/ was not found at scottcollins.net.
}}

(Now is) R.Invalid
Assignee: scc → nobody
Status: ASSIGNED → NEW
Keywords: helpwanted
OS: Other → Windows 95
QA Contact: sujay → sidebar
Whiteboard: HELPWANTED
Target Milestone: Future → ---
Version: Trunk → 1.0 Branch
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.