Getting started / Meet Mozilla Firefox Animation bug

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Marc-Olivier Laux, Assigned: vivganes)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

On animation showing new Firefox 4 features, when missing a marker (in crossing over it) and then coming back quickly to the target marker, both the marker and the info-box are hidden.

Reproducible: Always

Steps to Reproduce:
1.Come over a marker
2.Leave it quickly
3.Come back quickly
Actual Results:  
Action has not displayed informations about the feature

Expected Results:  
Animation displays expected infos

Reproduced on chromium. Seems like a javascript effects conflict.

Comment 1

7 years ago
Thanks for filing!

Anthony & Raymond, it looks like that disappearing marker bug may not be totally solved after all - see comment #0. Can you investigate?
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Comment 2

6 years ago
I would like to take and work on this bug. Can anyone please assign it to me?

Thanks...

Updated

6 years ago
Assignee: nobody → caliberoviv
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All

Comment 3

6 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/013043d9d8623509795b7eb3dd7ad70602181be5
Fix bug 644564 - Animation bug
Added stop() call on tip, arrow and callout before processing any animation, to abort any ongoing animation.

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Pushed to production.

Updated

6 years ago
Duplicate of this bug: 649868
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.