"0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://testpilot/modules/feedback.js :: FeedbackManager_isInputUrl :: line 109"

RESOLVED FIXED in 1.2

Status

defect
P2
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: alex_mayorga, Assigned: jono)

Tracking

unspecified
x86
Windows Vista

Details

(Whiteboard: input, needs-integration, )

Attachments

(1 attachment)

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre
Build Identifier: 

Loading any "special page" causes an error to appear in the error console.
Some pages:
about:blank
about:plugins
Add-ons Manager

Reproducible: Always

Steps to Reproduce:
1. Press Ctrl+Shift+A to load Add-ons Manager
2. Check the Errors tab in the Error Console
Actual Results:  
Error below is shown in the Error Console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.host]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://testpilot/modules/feedback.js :: FeedbackManager_isInputUrl :: line 109"  data: no]

Expected Results:  
No error appears

http://groups.google.com/group/mozilla-labs-testpilot/browse_thread/thread/fd91cd47e691989e/b3fa8801728f4791
Assignee

Comment 1

8 years ago
Hi Alex,
Thanks for reporting the bug.  I've seen this too.  It doesn't seem to affect anything, so I think we just need to be catch the error or else check whether it's a "special" URL before attempting to parse it.
Priority: -- → P2
Whiteboard: input
Target Milestone: --- → 1.2
Assignee

Comment 2

8 years ago
Fixed in http://hg.mozilla.org/labs/testpilot/rev/a875928fabfa
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 638983
Assignee

Comment 4

8 years ago
Assignee: nobody → jdicarlo
Status: RESOLVED → REOPENED
Ever confirmed: true
Attachment #524916 - Flags: review?(mark.finkle)
Resolution: FIXED → ---
Assignee

Updated

8 years ago
Whiteboard: input → input, needs-integration
Comment on attachment 524916 [details] [diff] [review]
Patch to mozilla-central to fix this bug

     if (uri.host == "input.mozilla.com") {
>+        if (path.indexOf("feedback" > -1) || path.indexOf("happy" > -1) || path.indexOf("sad" > -1)) {

You already fixed this parens bug in bug 645982

Otherwise looks OK
Attachment #524916 - Flags: review?(mark.finkle) → review+
Assignee

Comment 6

8 years ago
mfinkle: Is this landed?  If it is I will close the bug.
Assignee

Updated

8 years ago
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.