Last Comment Bug 644597 - Click menu "admissions" then nothing happened on www.baldwinschool.org
: Click menu "admissions" then nothing happened on www.baldwinschool.org
Status: RESOLVED FIXED
: regression
Product: Tech Evangelism
Classification: Other
Component: Desktop (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.baldwinschool.org/
Depends on:
Blocks: 374216
  Show dependency treegraph
 
Reported: 2011-03-24 07:58 PDT by Alice0775 White
Modified: 2014-09-16 23:03 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Alice0775 White 2011-03-24 07:58:57 PDT
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre ID:20110324030442

See https://support.mozilla.com/en-US/questions/796534

Click menu "admissions" then nothing happened.

This happens on Firefox4.0, Minefield4.2a1pre and Opera11.01.
This does not happen on Firefox3.6.x, Google Chrome12.0.711.0 canary build.
(I did not try IE and other browser)

In error console:

Error: subMenu.runtimeStyle is undefined
Source file: http://www.baldwinschool.org/ScriptResource.axd?d=7b1p6dMoHrHursMMKb_01R5qfWHLVhz5H_MlBKo-EdRhstXcVsVtyB0mGbgKFIo4nRGBy_236Gq0XMdK-tAjVeHelIP74yj8we-trS491hNA2l1qtoplrAtbyx0ur_LEmvI9Btz7y92FUF3UlX2CC5l3ZrGiM4Vtnm_sSSHCnLlKAMcCSIDl5aqzToZP1nMFw0l6s9nUvTO2EGwkbC2XW_FpCX2xEuFjWZmRafi3VkO3GGBw0&t=ffffffffeda9ebad
Line: 370


Steps to Reproduce:
1. Start Minefield with new profile
2. Open ( http://www.baldwinschool.org/ ) 
3. Click "admissions"

Actual Results:
 Nothing happens

Expected Results:
 Pull down menu should pop up.

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/173248959f01
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100206 Minefield/3.7a2pre ID:20100206050229
Fails:
http://hg.mozilla.org/mozilla-central/rev/05c983938253
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100208 Minefield/3.7a2pre ID:20100208050429
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=173248959f01&tochange=05c983938253

In local build,
build from 582494927009 : fails
build from bc6f2b598ff9 : fails
build from 2f0b9d7d8c56 : works
Regressed by:
bc6f2b598ff9	Robert Longson — Bug 374216 - Setting element.style.someSvgProperty has no effect. r=dbaron,sr=roc
Comment 1 Boris Zbarsky [:bz] 2011-03-24 08:16:22 PDT
Doesn't happen on Mac either.  The problem is that this page sniffs for IE in a broken way:

  if(ig_csom.IsMac || (subMenu.style.filter == null)) {
    subMenu.style.display="";
  }
  else {
    subMenu.runtimeStyle.filter = "";
  }

The checkin for bug 374216 made it so |style.filter| is not null.  But we don't implement the runtimeStyle IE-ism.

This needs a site fix.
Comment 2 Boris Zbarsky [:bz] 2011-03-24 08:27:27 PDT
I tried contacting the school, through their generic form.  We'll see where that gets us.
Comment 3 Karl Dubost :karlcow 2014-09-16 23:03:06 PDT
Pull down is working.

Note You need to log in before you can comment on or make changes to this bug.