Appointment Alarm Notification Occurs Hours instead of Minutes as defined

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Springwolf, Unassigned)

Tracking

Lightning 1.0b2
x86
Windows XP

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Lightning/1.0b2 Thunderbird/3.1.9

I have Alarm notifications set 5 minutes prior to the appointment. However notifications are occurring at least 3 hours prior to the meeting time. I have verified the computers clock and it is correct. This occurs on all recurring appointments. I don't know if it also occurs on single occurrence meetings, I don't have any of those. 

Reproducible: Always

Steps to Reproduce:
1. Define recurring appointment (daily or weekly) and set the Reminder to 5 minutes. 
2. 
3.
Actual Results:  
3 hours prior to the meeting time, the reminder pop up appears. I can snooze the meeting for several hours. 

Expected Results:  
Display the alarm reminder 5 minutes prior to the meeting time.
(Reporter)

Comment 1

7 years ago
I've researched and searched for others with a similar problem, but I haven't been able to find anyone else who has run into this.
Version: unspecified → Lightning 1.0b2
Hmm strange. Could you enable calendar.debug.log and calendar.debug.log.verbose and retry? There should be lots of log messages regarding the alarm service.

What calendar server are you using (or local calendar) ? What timezone are you in? Does the OS timezone match the timezone set in Lightning?

Please create a test event and try it on a non-recurring event.

Comment 3

7 years ago
Vickie could you please report more details? Otherwise this bug will be closed soon.

Reminders work fine for me.
(Reporter)

Comment 4

7 years ago
Sorry guys, I had forgotten about this. I upgraded all around since this issue was reported and the problem I was having went away. I'll paste the current configuration below for others who maybe having the problem. But just to round this out for others, let me answer the questions:

I looked for how to turn on debugging and wasn't successful. I didn't take time to google a solution. So you may want to tell people how to do that next time you want them to. 

Calendar server: local
TimeZone: America/NewYork
OS Time Zone does match. 
The issue occurred on both recurring appointments and non-recurring. 

If someone else is having this problem, I suggest upgrading. This is what I'm running now and the problem is no longer occurring. 

Name Thunderbird 
Version 6.0.2 
User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20110902
           Thunderbird/6.0.2
Application Build ID 20110902221921

Name Lightning
Version 1.0b5

Comment 5

7 years ago
Hi Vikie,

thanks for the fast response. I am glad that the problem has been solved by now.

For others that get here information on how to enable logging is at <https://wiki.mozilla.org/Calendar:QA_CalDAV_Support#Diagnosis_hints>.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.